Getting Password Protect to play nicely with Visual Composer

Hey folks, I'm trying to get Password Protect to play nicely with Visual Composer. After creating my post/page content in VC I then switch back to classic editor to see the shortcode generated.

I wrap the required content with Password Protect but no joy on viewing page as content is messed up.

Any advice?

  • Patrick
    • Support Monkey

    Hi there @graffig

    Welcome to the forums, glad to have you aboard!

    Yah, Visual Composer aligns everything on a single line when you switch to classic editor, so it's just too easy to muck things up when wrapping its shortcodes in other shortcodes.

    So before doing so, adjust the Visual Composer shortcodes so each on is on a separate line. That will make it much easier to see exactly what you need to wrap with password-protect shortcodes.

    Here's an example from one of my test sites:

    [protect password="password"]
    [vc_row]
    [vc_column width="1/1"]
    [vc_column_text]I am a password protected text block.[/vc_column_text]
    [/vc_column]
    [/vc_row]
    [/protect]
    
    [protect password="password"]
    [vc_row]
    [vc_column width="1/1"]
    [vc_video title="Enter password to watch this video" link="http://youtu.be/ccnwzScp6bM"]
    [/vc_column]
    [/vc_row]
    [/protect]

    When it's cleaned up like above, it's much easier to see where things get buggered up. Here's a link to the actual test page:
    http://reallywantthis.com/sample-page/

    I hope this helps! And thanks for being a member :slight_smile:

  • ken_lyle
    • Design Lord, Child of Thor

    Hey, Patrick!

    I am struggling with this, too.

    Something is eating all the HTML tags, including, p, form, and input.

    I need a solution for protecting full pages, not a shortcode solution.

    The theme in question is Subway by Qode from Themeforest.

    Ideas?

  • Michael Bissett
    • Recruit

    Hey @ken_lyle, hope you're doing well this evening! :slight_smile:

    We'd be more than glad to help you get the issue you've run into sorted out, but given the age of this thread, it would be best to create a new thread for your issue:

    https://premium.wpmudev.org/forums/#question

    In the meantime though, I'll be marking this thread as resolved, as the member that opened this question is no longer an active subscriber.

    Kind Regards,
    Michael

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.