getting rid of www on multisite (subsites)

Hello.

I recently started a multisite site and, by default, it showed up with www. I added a couple of sites later and then followed this article (http://www.tcbarrett.com/2013/07/how-to-remove-www-from-your-wordpress-network-multisite-primary-domain/#.WGU_v6IrLdQ) to try and remove the 'www' but at this point, when I go to any of the subsites, they still show up www.

Example:
Primary domain: upfrontchildthemes.com

Works fine.

Second site (what I'm calling a 'subsite' above): /eleanor

If I go to upfrontchildthemes.com/eleanor, however, it appears to redirect to http://www.upfrontchildthemes.com/eleanor

I just want it to go to the non-www deal...

NOTE - support is active until 6 JAN 2017.

Thanks!

  • Rupok

    Hi Logan,

    Thanks for granting Support Access. I logged in to see the issue and I could see it live on your site. However, I created a test subsite to regenerate this issue but the subsite is loading without the "www" part. So I think, somewhere in the database, your previous two subsites still has site URL with "www" part.

    Can you please login to your PHPMyAdmin and check your "wp_2_options" table and "wp_3_options" tables (I assume your database prefix is "wp_") and check the "siteurl" and "home" options? If you see subsite URLs with "www" part, can you edit those fields and remove the "www" part from the URL and check if it resolves your issue? I believe it will.

    If it doesn't, can you please delete those two subsites and re-create them? From now on, your subsites won't show "www" in the URL as my newly created test subsite on your network is not showing "www" in the URL.

    Please let us know if you have any confusion. We will be glad to help.

    Have a nice day. Cheers!
    Rupok

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.