getting snapshot 500 error

I try to get snapshot. But then I come to a site where I must buy storage. I don’t want that I just want to see what it is all about. Is there any other way to look into snapshot? what i want to know is the answer to my question: if I have site a, b, c, d on my network, can I restore site c only?

  • Dimitris
    • Support Star

    Hey there Piet,

    hope you’re doing good and thanks for joining us! :slight_smile:

    There’s no reason for you to buy additional storage to check Snapshot.

    To get this from the beginning, as you’re on trial here with us, you should first install our WPMUDEV Dashboard plugin as described here

    From there, you should be able to install all of our plugins and themes. You can also use it in as many sites as you want!

    Now, Snapshot plugin can perform backups locally in your server, even for a single subsite of your multisite installation, and apart from storing these locally to your server, you can use some extra destinations like a Dropbox or Google Drive account, or even another server via FTP details.

    All of these can be found in usage page of Snapshot product page here:

    Additionally to old-good snapshots, we introduced “Managed Backups” as you can see in our introduction blog post here:

    These Managed Backups are backing up the whole multisite installation instead and it’s being stored to our cloud servers. Your WPMUDEV membership comes with a 10GB limit in total for all of yours managed backups from all of your websites.

    Additionally to Managed Backups and as more of our members requested that, we introduced some additional storage plans in case this 10GB limit is small for your needs.

    Hope that clarifies things a bit, please let me know if more assistance is required as I also see a “error 500” in threads title but no reference afterwards.

    Warm regards,


    PS. As a trialist here with us, please have a quick read on “How Free Trial Work” page here.

  • Piet
    • Flash Drive

    ok Dimitris, I get this:

    Server error status: Internal Server Error [500]



    Hang on a minute… It looks like your WordPress site isn’t configured to allow one-click installations of plugins and themes. But don’t worry! You can still install this plugin by entering your server’s FTP credentials here:

    FTP Username


    FTP Password


    FTP Host


    We will remember these details for 15 minutes in case you want to install or, update something else.

    Or you can enable one-click installations on this site by adding the following details to wp-config.php:

    define( ‘FTP_USER’, ‘your FTP username’ );

    define( ‘FTP_PASS’, ‘your FTP password’ );

    define( ‘FTP_HOST’, ‘’ );

    It gives me the opportunity to fill in my password, but when I do it comes with the 500 error.

    what to do? Piet.

  • Predrag Dubajic
    • Support

    Hi Piet,

    Can you give us some more info about the issue you’re having, where exactly does it show, can you tell us the steps you did when you saw the above message?

    Could you provide us with some screenshots of the issue so we can better understand what’s going on?

    These messages are usually related to server limitations, can you ask your host to check permissions of your WP folders?

    Best regards,


  • Piet
    • Flash Drive

    Hi, I am on mu network in WPMU DEV in plugins. The dashboard is given as being activated, the rest of the plugins are marked INSTAL.

    When I press INSTAL on Snapshot, it comes with the page I send you. I fill in the password and then it comes with an 500 error.

    Can you tell me what permissions are needed for which WP folders? 777 or 755 or something else? ANd for which folder. I can check that.

    Directory mu-plugins 8.00k 755 Protect

    Rename | Copy

    Reset Owner | Recursively Jul 31 16:06 2015 apache apache

    i see this in my file manager. Is this one all right?

  • Predrag Dubajic
    • Support

    Hi Piet,

    I’m sorry but I’m still not sure that I understand which page are you seeing, is it something from WPMU DEV or your server… Would you mind allowing support access so we can have a closer look at this?

    To enable support access you can follow this guide here:

    As for the permissions, try setting wp-content as well as wp-content/plugins to 755.

    Best regards,


  • Predrag Dubajic
    • Support

    Hi Piet,

    Can you enable debug log in your wp-config.php by replacing define(‘WP_DEBUG’, false); with this code:

    // Enable WP_DEBUG mode
    define('WP_DEBUG', true);

    // Enable Debug logging to the /wp-content/debug.log file
    define('WP_DEBUG_LOG', true);

    // Disable display of errors and warnings
    define('WP_DEBUG_DISPLAY', false);
    @ini_set( 'display_errors', 0 );

    Try installing the plugin again and this should create debug.log file in your wp-content folder that could tell us what is going on.

    Can you please save it as .txt file and attach it here so we can check it out.

    Also, have you tried with adding the FTP connection code in your wp-config.php to see if you can install plugins after that?

    This is the code I’m referring to:

    define( 'FTP_USER', 'your FTP username' );
    define( 'FTP_PASS', 'your FTP password' );
    define( 'FTP_HOST', '' );

    Replace the username and password and add the code above /* That’s all, stop editing! Happy blogging. */ line in your wp-config.php and see if it works after that.

    Best regards,


  • Piet
    • Flash Drive

    Hello Pedrag,

    I did what you said but how the %%$# do I do this: Can you please save it as .txt file and attach it here so we can check it out.

    It still gives the 500 error, but no longer the screen demanding my password. So the password works.

    I just don’t know how to attach the file here. I found and saw the log file. just how do I get it here.

    Regards, Piet.

  • Predrag Dubajic
    • Support

    Hi Piet,

    When you download the file on your PC you can simply rename the file so instead of debug.log it's named debug.txt.

    Or you can open the debug.log with any text editor and then save as .txt file.

    After that you can click on attach icon and select your debug.txt file.

    Best regards,


  • Predrag Dubajic
    • Support

    Hi Piet,

    Sorry for the delay, we have unusual high number of threads last few days and were doing our best to get back to everyone.

    Unfortunately I don’t see any file attached with your comment, can you please try again and check your comment after posting to see if the comment is attached.

    You should see the file at the bottom of your comment, as the example file attached to this comment.

    If you’re still having troubles attaching it can you upload it to any file sharing service like dropbox or google drive and share the download link.

    Best regards,


  • Adam Czajczyk
    • Support Gorilla

    Hello Piet!

    Please follow these steps:

    1. Go to "Snapshot -> Managed Backups" page

    2. Click on "here" link right below the "Your secret key here" text field:

    3. (Optional, if prompted) on a page that loads in browser, click on "Login to the hub" and use your WPMU DEV credentials to login to the site:

    4. (Optional, if point 3 was necessary) repeat steps 1 and 2 and you'll be given a popup like this:

    5. Copy the key and paste it to the "Your secret key here" field on "Snapshot -> Managed Backups" page and hit "Activate Managed Backups" button.

    If you are asked to buy an additional storage space "on a way" simply dismiss the message, you can always buy additional space later if needed.

    Give it a try please and let me know if it worked.

    Best regards,


Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.