Getting some warnings/errors related to Hummingbird cache on the frontend of my site

I’m getting these errors on the frontend of my site:
Warning: preg_match(): Compilation failed: nothing to repeat at offset 35 in /home//+++.com/wp-content/plugins/wp-hummingbird/core/modules/class-module-page-cache. php on line 470

Warning: Cannot modify header information - headers already sent by (output started at /home//m.s.com/wp-content/plugins/wp-hummingbird/core/modules/class-module-page-cache. php:470) in /home//+++/wp-content/plugins/wp-hummingbird/core/modules/class-module-page-cache. php on line 975

Warning: Cannot modify header information - headers already sent by (output started at /home//+++/wp-content/plugins/wp-hummingbird/core/modules/class-module-page-cache. php:470) in /home//m.s.com/wp-content/plugins/wp-hummingbird/core/modules/class-module-page-cache. php on line 975

Warning: Cannot modify header information - headers already sent by (output started at /home//+++/wp-content/plugins/wp-hummingbird/core/modules/class-module-page-cache. php:470) in /home//m.s.com/wp-content/plugins/wp-hummingbird/core/modules/class-module-page-cache. php on line 975

Warning: Cannot modify header information - headers already sent by (output started at /home//+++/wp-content/plugins/wp-hummingbird/core/modules/class-module-page-cache. php:470) in /home//+++/wp-content/plugins/wp-hummingbird/core/modules/class-module-page-cache. php on line 979

  • Adam Czajczyk

    Hello Jean Pierre,

    I hope you're well today and thank you for your question!

    I checked the site and the issue was caused by "Exclusions" list on "Hummingibird -> Caching -> Page Cache" settings page. In addition to default rule, there were these three lines added:

    *\/checkout\/*
    *\/cart\/*
    *\/account\/*

    I assume that the goal here was to exclude entirely all the pages that include "checkout", "cart" and "account" slugs. However, if you test these lines with a regex validator (e.g here https://www.freeformatter.com/regex-tester.html) you will find that they report exactly the same error "Nothing to repeat" - they are not valid here.

    In order to exclude those pages it would suffice to use these strings:

    /checkout/
    /cart/
    /account/

    I set the exclusion list like that and the error is now gone.

    I hope that helps and if you have any additional questions, let me know please.

    Kind regards,
    Adam

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.