getting warning message after recent wp update

I get this warning and don't know what to do with it:

Warning: Creating default object from empty value in /home/techrive/public_html/wp-content/themes/Aggregate/epanel/custom_functions.php on line 859

Warning: Creating default object from empty value in /home/techrive/public_html/wp-content/themes/Aggregate/epanel/custom_functions.php on line 859

Also, I notice after the update, the "add media" button in the wysiwyg editor no longer works. I can load images into library, but, can no longer add them to posts. Could this be related?

I have enabled support access. Thank you in advance for your help. Linda @iempower

  • Kasia Swiderska

    Hello Linda,

    Warnings are pointing to theme Aggregate that is from Elegant Themes - it looks like something broke in that theme after update.
    So you should update that theme to latest version that is compatible with new WordPress.
    If there is no update then you should report this issue to theme developers, so they will fix it.

    You can also check if you have in your wp-config.php that line

    define('WP_DEBUG', true);

    if yes, then change it to

    define('WP_DEBUG', false);

    that in some cases should prevent displaying errors on front end (this might not work). And will not fix this issue

    Also, I notice after the update, the "add media" button in the wysiwyg editor no longer works. I can load images into library, but, can no longer add them to posts. Could this be related?

    It can be related - but to be sure please run a quick plugin/theme conflict test as illustrated in getting support manual (flowchart). Let me know how it goes.
    http://premium.wpmudev.org/manuals/using-wpmu-dev/getting-support/

    kind regards,
    Kasia