Global Search

I just got this plugin and it says its compatible up to 3.5 on the site, but when you download the plugin and install, and read the installation text, it says its only up to wp 2.9. Is this true? and if so, what are my other alternatives since I was to believe it was compatible with WP 3.0+

Very Disappointed