Global Search table bug marketpress

Hi,

I am using Marketpress in Multisite configuration with global cart. I found one little bug (i think). When i add a new product and set the price to for example 3 and hit publish. It saves to price okay in the post_meta table. But it doesn't save it in the wp_mp_products table. Only when i hit the update button again for that product it updates the price there. My guess is that the price which goes in wp_mp_products table is 'Sale price' which at the time of publishing is 0, but when the page reloads, its prepopulated by the 'price' field value. So now when the product is updated, it takes that value.

  • Alexander
    • DEV MAN’s Mascot

    Hi @Mindblaze,

    I'm sorry about the delay here. I've done some more in depth testing here and I can confirm a few things. It is using the sale price if one is selected. It's also not being set to that sale price initially.

    I didn't notice this actually affecting anything though. Was it causing any issues?

    I'm not sure if this is a bug or not, but I'll mention it to @Aaron so he can take a look.

    Best regards,

  • Mindblaze
    • The Incredible Code Injector

    Hi Alexander,

    No worries!

    Yes, the sale price is not set initially which is used for that table at wp_mp_products.

    The affect it is causing me is that when i use wp_mp_products table to show global products, most of them show '0' price. :slight_smile:

    Thank you for this.

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.