global site search doesn't work anymore

Hello!

the search doesn't work anymore?!

can you have a look please? thanks!

  • Bojan Radonic

    Hey there Daniel,

    How are you doing today?

    When you say that "the search doesn't work anymore?!" does it mean it stopped working on a site where it used to work before or it's not working on a new site that you just tried to set it up?

    I've tested Global Site Search on my sandbox site and it was working without any issues, would you mind granting me temporary admin access via our WPMU DEV Dashboard plugin so I can take a look? You'll find more info on how to grant access by following this link: https://premium.wpmudev.org/manuals/wpmu-dev-dashboard-enabling-staff-login/

    Looking forward for your reply :slight_smile:

    Cheers,
    Bojan

  • Bojan Radonic

    Hey Daniel,

    I checked your site and there is indeed no results being printed when you run a search. There is a single JS error in the console related to Google Maps API key not being entered in your theme options but that shouldn't be what's causing this.

    Since posts are properly indexed and you also mentioned that this worked before it's most likely related to a conflict with the theme that you're using or another plugin so we'll have to do a conflict test to see which one is causing this if any.

    Perhaps you can remember which plugin you installed last when this started happening or an update cause this would be a good place to start.

    What we need to do is temporarily deactivate all plugins, switch to default WP theme like TwentySixteen and see if the issue persists, if not activate them one by one or in batches to see which plugin/theme is conflicting with it.

    Alternatively if you don't want to do this on your live site you could clone your site and make a staging version where you could test this.

    Please let me know if you find anything :slight_smile:

    Cheers,
    Bojan

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.