Global site tags plugin is not working

Global site tags plugin does not show the tags. I already installed post indexer plugin and looks like it is working. But Global Site Tags not.

  • James Morris

    Hello Creative Blogs,

    I hope you are well today. I'll be following up with you regarding your chat.

    I'm afraid I've not been able to determine the source of the problem just through your WP Admin Dashboard. I'm afraid I'm going to need FTP access in order to dig into this issue deeper.

    In order to help you better with your issue, would you please grant me access to your server?

    Please visit the Contact page and complete the form with the following information:

    Subject: "Attn: James Morris"

    In the Message box, please provide the following:

    - link back to this thread for reference
    - any other relevant urls

    - Hosting Control Panel Login
    Admin username
    Admin password
    Login url

    ~OR~

    - FTP credentials
    host
    username
    password
    (and port if required)

    Best regards,

    James Morris

  • James Morris

    Hello Creative Blogs,

    Sorry for the delay here. I've done some extensive testing on my own environment. I setup my environment to be similar to yours.

    What I've found is, with a default install of WordPress, Global Site Tags works as expected. However, once I installed and activated Wordfence, GST stopped working and threw some JS Console errors. I was able to reproduce this on both your site and my own environment.

    As such, I'm reporting this as a confirmed bug for our Dev Team to investigate further. An update will be posted once a solution is found for this issue.

    Best regards,

    James Morris

  • James Morris

    Hello Creative Blogs,

    I've checked the related task for this and I see that this bug has been assigned to a developer, but beyond that I have no further details to report. I've pinged the developer and asked for an update.

    Please keep in mind that issues like this can take a bit longer and must first be run through our QA team to ensure compatibility and code quality standards.

    As soon as more information is available, an update will be posted.

    Best regards,

    James Morris

  • Panos

    Hi John!

    Apologies for delay!

    It seems that this is related with your db. Can't be 100% sure yet, it seems that error logging has been disabled from server so I can't check much. Of what I was able to check, it seems that we can't insert new records to network_terms table. I can't check any logs with db errors either, perhaps you could check via phpMyAdmin from your cPanel if that table has any content. I can't get any results when selecting all from that table.

    Thanks!

  • Creative Blogs

    Hi Panos

    I hope this information is useful:

    mysql> show tables like '%term%';

    +-----------------------------------+

    | Tables_in_garstonprimary (%term%) |

    +-----------------------------------+

    | gp_10_term_relationships |

    | gp_10_term_taxonomy |

    | gp_10_termmeta |

    | gp_10_terms |

    | gp_11_term_relationships |

    | gp_11_term_taxonomy |

    | gp_11_termmeta |

    | gp_11_terms |

    | gp_12_term_relationships |

    | gp_12_term_taxonomy |

    | gp_12_termmeta |

    | gp_12_terms |

    | gp_13_term_relationships |

    | gp_13_term_taxonomy |

    | gp_13_termmeta |

    | gp_13_terms |

    | gp_14_term_relationships |

    | gp_14_term_taxonomy |

    | gp_14_termmeta |

    | gp_14_terms |

    | gp_2_term_relationships |

    | gp_2_term_taxonomy |

    | gp_2_termmeta |

    | gp_2_terms |

    | gp_4_term_relationships |

    | gp_4_term_taxonomy |

    | gp_4_termmeta |

    | gp_4_terms |

    | gp_5_term_relationships |

    | gp_5_term_taxonomy |

    | gp_5_termmeta |

    | gp_5_terms |

    | gp_6_term_relationships |

    | gp_6_term_taxonomy |

    | gp_6_termmeta |

    | gp_6_terms |

    | gp_7_term_relationships |

    | gp_7_term_taxonomy |

    | gp_7_termmeta |

    | gp_7_terms |

    | gp_8_term_relationships |

    | gp_8_term_taxonomy |

    | gp_8_termmeta |

    | gp_8_terms |

    | gp_9_term_relationships |

    | gp_9_term_taxonomy |

    | gp_9_termmeta |

    | gp_9_terms |

    | gp_network_term_relationships |

    | gp_network_term_taxonomy |

    | gp_term_relationships |

    | gp_term_taxonomy |

    | gp_termmeta |

    | gp_terms |

    +-----------------------------------+

    54 rows in set (0.00 sec)

    In the apache logs we get:

    WordPress database error Table 'garstonprimary.gp_network_terms' doesn't exist for query \r\n\t\t\tSELECT COUNT(*) as 'count',\r\n\t\t\t t.term_id,\r\n\t\t\t\t t.term_id as id,\r\n\t\t\t\t t.name,\r\n\t\t\t\t t.slug,\r\n\t\t\t\t t.term_group,\r\n\t\t\t\t tt.term_taxonomy_id,\r\n\t\t\t\t tt.taxonomy,\r\n\t\t\t\t tt.description,\r\n\t\t\t\t tt.parent,\r\n\t\t\t\t CONCAT('https://garstonprimary.co.uk/tags/', t.slug) as 'link'\r\n\t\t\t FROM gp_network_terms as t\r\n\t\t\t INNER JOIN gp_network_term_taxonomy AS tt ON t.term_id = tt.term_id\r\n\t\t\t INNER JOIN gp_network_term_relationships AS tr ON tt.term_taxonomy_id = tr.term_taxonomy_id\r\n\t\t\t INNER JOIN gp_network_posts AS np ON np.ID = tr.object_id AND np.BLOG_ID = tr.blog_id\r\n\t\t\t WHERE tt.taxonomy = 'post_tag' AND t.name NOT IN ('') AND np.post_type = 'post' GROUP BY t.term_id ORDER BY 'count' DESC LIMIT 50 made by require('wp-blog-header.php'), require_once('wp-includes/template-loader.php'), include('/themes/forthecause/index.php'), get_footer, locate_template, load_template, require_once('/themes/forthecause/footer.php'), woo_sidebar, dynamic_sidebar, call_user_func_array, WP_Widget->display_callback, widget_global_site_tags->widget, globalsitetags->global_site_tags_tag_cloud

    The table not existing would certainly explain the problem!

    Can you advise the next steps?

  • Panos

    Hi Creative Blogs ,

    I apologize for taking so long to reply back!

    That table shouldn't be missing, as that is where it SELECTs the tags from. It should be created upon Post Indexer activation, but it seems there is some limitation that didn't allow it to create it.

    I also tried to create it via a mu-plugin, but again it didn't. Given that the debug.log doesn't print anything (I have enabled it from wp-config.php), I can't be really sure why it's not created. I suppose some limit on the varchar type.

    You could try creating that table manually via phpMyAdmin. The table name should be:
    gp_network_terms

    and the columns of that table should be:

    term_id bigint(20) unsigned NOT NULL AUTO_INCREMENT,
    name varchar(200) NOT NULL DEFAULT '',
    slug varchar(191) NOT NULL DEFAULT '',
    term_group bigint(10) NOT NULL DEFAULT '0'

    If it doesn't get created you could try reducing the varchar size to 100 instead of 200, or less. If it still doesn't get created please share here what is the error message it displays.

    Thanks!