Good day, Pay Per View does perfectly hide my content

Good day, Pay Per View does perfectly hide my content in single view but still shows the content in list view. How do I hide it in list view? Thanks, Alex

  • Adam Czajczyk
    • Support Gorilla

    Hey Alex,

    I hope you're well today and thank you for your question!

    I'm not sure if I'm getting this correctly so let's please make sure that we're on the same side here :wink: I understand that on "single post/page" page Pay Per View is working for you as expected but it's not hiding any post content on post list page (e.g. "blog" page), is that right?

    You may wan't to give "multiple posts pages" option a try then. To do this, please go to your dashboard's "Pay Per View -> Pay Per View" page and in "Accessibility Settings" section set "Enable for multiple post pages" option to "Yes" then save settings and see if it worked.

    Let me know please if it worked for you. If it don't, please grant me a support access to your site so I could take a closer look at you setup. You may do this by following this guide:

    https://premium.wpmudev.org/forums/topic/more-a-thanks-than-a-question-about-wp-defender

    Best regards,
    Adam

  • Alex
    • Flash Drive

    Hi Adam and thanks for your support. Like you have explained content can be hidden on the single page but still appears on the post list page. I've tried to enable "multiple posts pages" but without success.
    The link you have sent me is about some other topic. But I'd gladly give you access to my blog.

  • Milan
    • WordPress Wizard

    Hello @alexandertichelli,

    I hope you are well today and sorry for being late on this. :slight_smile:

    Seems like by mistake my collegue Adam has provided wrong link. Right link for getting familiar with Support Staff access is this,
    https://premium.wpmudev.org/manuals/wpmu-dev-dashboard-enabling-staff-login/

    Now before you grant us support staff access, please follow these solution steps. If these steps can't conclude good solution for you please do enable support access to your site. :slight_smile:

    #1) Navigate to Dashboard > Pay Per View > Accessibility Settings > Set "Yes" for
    Enable on the home page
    option
    #2) Now just beneath "Enable on the home page" option you will see option saying "Enable for multiple post pages", set its value to "Yes" too.
    #3) Save Changes.

    That's it. Please view your blog listing page after these changes and let us know how it goes for you. :slight_smile:

    Cheers,
    Milan

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.