Google Analytics+ and switching from HTTP to HTTPS

Hi Guys, yesterday I updated my site and put it into https mode, I then updated the property settings in Google analytics from http to https so that the account remained tracking properly, I then installed the Google Analytics + and tested it on individual posts but it doesn’t seem to pull any data through, will this be due to the switch from http to https in my GA account?

Also how come in ‘Custom Google Analytics Statistics inside WordPress Dashboard’ the drop down includes duplicates of my properties? I only have 3 currently set up but the drop down has 6?

Thanks

Matt

  • Luís
    • Support

    Hi Matt ,

    Hope you’re doing well today!

    If I understood well, the statistics inside the dashboard doesn’t display live data like your actual Google Analytics account does – it just updates everyday to reflect the previous days stats.

    However, can you give us access to your admin panel, so we can check your issue?

    If you don’t already know, please, follow the link below, to see how enable the staff login:

    http://premium.wpmudev.org/manuals/wpmu-dev-dashboard-enabling-staff-login/

    When you enable this option, please post again!

    Cheers, Luís

  • Matt
    • Design Lord, Child of Thor

    Hi Guys, any update on this? I really need to get GA+ working as it should in order to enable more effective content reporting so would appreciate some feedback, it’s been 3 days since I opened ticket.

    Thanks

    Matt

  • Matt
    • Design Lord, Child of Thor

    Hi Guys, I granted support access on Sunday 5th March at 11am, it’s now Thursday 9th March 4pm and no one has accessed my site still??

    SUPPORT LOGINS

    No one from Support has logged in yet. Sit tight!

    How long should I usually have to sit tight for?

    Thanks

    Matt

  • Adam Czajczyk
    • Support Gorilla

    Hello Matt!

    I apologize for the delay. We’ve had some increased flow of questions recently and we were trying to keep up with all of them. Please note however, just for future reference, that when you grant an access we are not notified about this until you let us know so it’s best to post here as soon as access is enabled. Posting several posts in a row without staff response also works in an opposite way as on regular forums – it doesn’t “bump up” you ticket but marks it “newer” and we’re supposed to replay to all the tickets in order from “oldest to newest” to minimize waiting time. I think it’s good to know that and I’m sorry for keeping you waiting.

    As for the issue. I checked the site and I see that the Google Analytics is set to use data for “http://yourdomain.com….” site (take a look at “Custom Google Analytics Statistic Inside WordPress Dashboard” option on “Settings -> Google Analytics” page). In theory that shouldn’t be an issue but according to Google docs there should be a relevant protocol selected. Take a look here please:

    https://support.google.com/analytics/answer/1042508?hl=en

    You mentioned that you changed properties but the drop-down suggests that only one of the domains is set to use https:// prefix in Google Analytics setup. Could you double check this please?

    If that turns out not to be the case could you please create a new “view” for the site, switch Google Analytics plugin to it and see if that’s catching up on proper data then?

    Kind regards,

    Adam

  • Matt
    • Design Lord, Child of Thor

    Hi Adam,

    Thanks for the feedback and I’ll bear this in mind going forward, it just seemed a little odd that I originally left if 48 hours before replying to the thread during which time no one from support had logged in, 2 days seemed a long time for support!

    I’ve just done some spring cleaning on my GA account and the ‘Property’ and ‘View’ are both now set up for HTTPS, there’s also definitely analytics for my individual posts but when I try to view data for individual posts its just a flat line…

    Is there something I’m missing?

    Thanks

    Matt

  • Adam Czajczyk
    • Support Gorilla

    Hello Matt!

    If I understand that correctly, the post stats are now the main issue, is that correct? I checked that on my end and since it’s working fine there I wanted to check your site again and compare my GA plugin setup with yours but the support access is no longer open. It’s time valid so it expires automatically. Could you please grant it again for me?

    Please let me know here when it’s granted so I’ll access your site again.

    Kind regards,

    Adam

  • Matt
    • Design Lord, Child of Thor

    Hi Adam,

    Support access has now been granted.

    And in answer to your question, yes, in post analytic are now the main issue yes.

    Also, is there anyway to alter the time frame instead of just for the past 30 days?

    Thanks

    Matt

  • Adam Czajczyk
    • Support Gorilla

    Hello Matt!

    Thank you for re-granting access.

    I have checked the site again and also dig a bit more into a plugin itself and I’d like you to try one more thing. Please use this plugin to clear WP transient cache:

    https://wordpress.org/plugins/artiss-transient-cleaner/

    Once it’s done, please also clear browser’s cache and check these stats again. Let me know please if that worked on your site. If it doesn’t help, I’ll need to ask developer for some help (I”ll also ask him about an option to change data range then).

    Best regards,

    Adam

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.