google analytics+ dash widget doesn't show up in a user (author) dashboard


I'm using the google anlytics+ plugin and as an admin works great but it doesn't show up on the dashboard when an other user with author role and capabilities logs in.
What capabilities does this plugin needs?

  • M1chel
    • WPMU DEV Initiate

    solved it, I think.
    Using Members plugin I set up a new custom role called "user" and the capability that makes the difference allowing to use and see Googl Analytics+ is "manage_options".
    You need that or you can't see/use the plugin.

    If you don't want your user to mess around with the Google Analytics options you can hide it from the menu by deactivating the "settings" for that role with Adminize plugin and it still shows the stats in the dashboard and in the widget but you don't have access to the options.

    I hope it helps everyone else until the release of the next revision of Google Analytics+

    I'll wait to mark it resolved until an admin sees it and can confirm.

  • Vinod Dalvi
    • WP Unicorn

    Hi @M1chel,

    Awesome, great to see you got that fixed.

    Yes you are right in the plugin the Statistics page is added in the dashboard using following code which needs manage_options capability.

    add_dashboard_page('Statistics', 'Statistics', 'manage_options', 'google-analytics-statistics', array( $this, 'google_analytics_statistics_page' ) );

    Please advise if you have more questions.

    Thank you for being a WPMU DEV member and have a great day!

    Vinod Dalvi

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.