Google Analytics Dashboard widget not displaying

For some reason, the Google Analytics dashboard widget is not displaying on subsites. It used to display so I'm not sure what may now be blocking it. The plugin is network activated but I also have integrated with Pro Sites. I'm checking sites that should have the dashboard widget based on level but it is not there.

  • Nastia

    Hello antKat , I trust you are doing well today!

    I can't reproduce the same on my installation. Would you please deactivate all the other plugins and test if the Statistic widget will be shown again.

    Also, please switch to a default WordPress theme. If you can see after all of this the widget, activate one plugin at the time to find out which one is causing this issue.

    Follow the flowchart from our Getting Support manual:
    https://premium.wpmudev.org/manuals/using-wpmu-dev/getting-support/

    Let us know how it went!

    Cheers,
    Nastia

  • antKat

    Thanks for the reply. Can you first tell me if Google Analytics is supposed to be network activated if it is integrated with Pro Sites. Most of the Pro Site premium plugins are explicitly not network activated. It was my understanding though that GA needed to be networked in order for use to get the global network stats. Just wondering if this could possibly be part of the issue.

    We have so, so many plugins. Isn't there a way to get a better clue regarding the possibility of a plugin conflict.

  • Panos

    Hello antKat ,

    Google analytics can be integrated with Pro Sites. If Network Activated you cna even choose which pro-sites level will have access, from network admin > Settings > Google Analytics, as in the following screen-shot:

    Regarding you issue, I suspect some js conflict from a plugin, as I see that there is an Affiliates chart in the Dashboard probably using the same js script.

    If you have ftp/cPanel access try editing file wp-content/plugins/google-analytics-async/google-analytics-async-files/class-google-analytics-async-dashboard.php at line ~720 and replace this
    add_action( 'admin_enqueue_scripts', array( &$this, 'admin_enqueue_scripts' ) );
    with this
    add_action( 'admin_enqueue_scripts', array( &$this, 'admin_enqueue_scripts' ), 11 );

    If ti doesn't work try replacing number 11 with 100. Please let us know how it goes or if you need any help implementing this change.

    Kind regards,
    Panos

  • Panos

    Hi antKat ,

    It's not normal not to show the dash widget as I tested in three test installations and shows in each one.

    Is your site live? If not it would be very helpful if you could provide ftp access so we can examine some plugin files, enable debuging and perhaps deactivating some plugins and switching themes for a while.

    You can send ftp credentials privately through our contact form: https://premium.wpmudev.org/contact/

    Select "I have a different question?" for your topic - this and the subject line ensure that it gets assigned to me.

    Send in:Subject: "Attn: Panos Lyrakis"
    - WordPress admin username
    - WordPress admin password
    - login url
    - FTP credentials (host/username/password)
    - link back to this thread for reference : https://premium.wpmudev.org/forums/topic/google-analytics-dashboard-widget-not-displaying
    - any other relevant urls

    I would also need your approval to create some additional sub-sites and perhaps users.

    Before providing ftp info I would strongly recommend to keep a backup of your site. You can keep a quick backup easily with our Snapshot plugin.

    Looking forward to your reply!

    Kind regards,
    Panos

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.