Google Analytics for Multisite page says works with 3.0.1 and NOT 3.1

This isn't really a support issue but rather a clarification issue.

I'm about to update my site to Wordpress Multisite 3.1 and Buddypress 1.2.8, but I want to make sure all of the plug-ins I use are updated to work correctly with 3.1.

It looks like the Google Analytics for WordPress Multisite plugin was updated on 2/18/11.

However, on the page for the plugin:

https://premium.wpmudev.org/project/google-analytics-for-wordpress-mu-sitewide-and-single-blog-solution

It states that it works with Wordpress Multisite 3.0.1 instead of Wordpress Multisite 3.1. I was wondering if this was an error, or if it is not ready yet.