Google Analytics not Showing Stats on Individual Posts

Hi,

I am trying to get stats on specific posts inside the Edit Post window and every time I click for all posts it shows a flat line for the post.

I know the posts are getting traffic because it is reflecting in Google Analytics. It also appears that the plugin is set up correctly because I get the analytics for the entire site in the admin panel.

I looked but couldn’t find a setting to activate them in the specific posts. How do I get that working?

The reason I want this is because we have a multi-author blog and I want the contributors to be able to see the analytics on their particular posts.

Thanks,

Jesse

  • Vinod Dalvi
    • WP Unicorn

    Hi Jesse,

    I hope you are well today and thanks for posting on the forum.

    I can see you are using older version of Google Analytics + plugin so could you please try using latest version of it?

    If this doesn’t work for you using latest version of Google Analytics + plugin then would you mind if I logged in to your site and did some troubleshooting? This might help get to the bottom of this faster. If this is ok, just grant me temporary admin access to your site by clicking “Grant Access” button in the WPMU DEV Dashboard Settings as described on the following page and reply on this thread after granting it?

    Grant WPMU DEV Support Access

    Kind Regards,

    Vinod Dalvi

  • Jesse
    • Site Builder, Child of Zeus

    Hi Vinod, I updated but am still experiencing the same issue. I have granted access to the staging environment to you.

    Thanks,

    Jesse

    PS, I like that you are doing popular posts in there. I am using another plugin now, so it will be nice to get rid of that.

  • Vinod Dalvi
    • WP Unicorn

    Hi Jesse,

    Thank you for granting the support staff access.

    I could confirm the issue on your site and found the JavaScript error message is displaying in the edit post screen as shown in the attached screenshot which may be causing this issue.

    This can be due to plugin/theme conflict on your site.

    You can just try on your development site temporary using default WordPress theme like Twenty Fifteen and temporary deactivating all other plugins as displayed in the following flowchart to know which theme/plugin is conflicting if any.

    https://premium.wpmudev.org/manuals/getting-support/

    PS, I like that you are doing popular posts in there. I am using another plugin now, so it will be nice to get rid of that.

    You can try using the attached small plugin to achieve this.

    Regards,

    Vinod Dalvi

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.