Google Calendar API

Hi, I am not being able to generate the access code. I receive this message:
access_type=offline
approval_prompt=auto
scope=https://www.googleapis.com/auth/calendar
response_type=code
redirect_uri=urn:ietf:wg:oauth:2.0:oob
client_id= 933112506172-jibn6te1smd49piioll88a3k8gigm8rj.apps.googleusercontent.com
I suppose I must be doing something wrong in google console. Can you please help me?

  • Vilma
    • Design Lord, Child of Thor

    I am sorry Ivan, but it didn't help me much. I could understand that I am messing up in the way I am filling the info on the console, specially regarding "Authorized JavaScript origins" and "Authorized redirect URIs". I am really not sure what to put in those fields. My site is http://www.addarte.com and my host is bluehost.com I don't know if this can help you to tell me exactly what I should put in those fields in other to make it work. Attached are two screens: the error screen I get when I try to get the code (Google Calendar API: Authorize access to my Google Application) and the screen in google console I believe I am not filling up properly. I'd highly appreciate if you could just tell me what to place in those fields because I think this is the only thing that is missing for me to get the code.

  • Vilma
    • Design Lord, Child of Thor

    I am extremely frustrated because I am not being able to generate the Google Calendar API access code while trying to set up appointment plus plugin. I am searching for tutorials everywhere on the net, in youtube, in wpmudev documentations and google tutorials but I can't find anything that looks like the screens I get at present.
    I followed the instructions you give in the plugin's dashboard but it is not working!
    I already sent 2 requests for help, the first one you gave me a link to an answer given to another person but it didn't help me much.
    I will try to explain my problem again.
    I followed all the steps explained in appointment plus plugin's dashboard. I've already created a client id and pasted it on the proper field. But when I click on the "generate your access code", I am taken to the screen I attached here.
    What am I doing wrong? Where can I get updated instructions on how to do this? Is there any step by step tutorial of this whole process?
    In the answer that was given to the other member in the link you sent I understood the URI was wrong or something, but in the instructions it says " In the Authorized redirect URI field, delete the default value", as if we should just ignore that field.
    I don't even know what an URI is, and I've been trying to understand it, I am not sure if it is a page I should create to place a link on that field, and if this URL is what they call URI.
    If you can't teach me all those things, please, tell me where can I find an updated tutorial.

  • Vilma
    • Design Lord, Child of Thor

    Hi, Luís,
    I was so excited when I saw your video because all the screens were exactly like mine, appointment plus settings and google developers console. This video is great because it is updated. I followed all steps, in fact, they were not that different from what I was already doing, but I followed it all again, step by step, in that same way, nonetheless I keep getting an error message
    access_type=offline
    approval_prompt=auto
    scope=https://www.googleapis.com/auth/calendar
    response_type=code
    redirect_uri=urn:ietf:wg:oauth:2.0:oob
    client_id= 1059425003179-5ohk3tmcnsirf4ifa6snp74jhhfioug5.app
    It is a little different from the message I used to receive, but it is an error message all the same. Something is not working on my end and I can't figure it out.
    My first trial week is gone and I haven't being able to try the plugin per se. It is quite frustrating. I don't know what else to do.

  • Vilma
    • Design Lord, Child of Thor

    Oh, Luís, I really wish you were right and an inexplicable space had been creating this nightmare, but no. I tried to eliminate it and got the same error message.
    The worst thing about having to do this process over and over again is that I have to uninstall, delete, reinstall and reactive the plugin all over again every time I try to set it up.
    Anyway, my suspicion is that something must be wrong in my google developer console, it is the only explanation. If I am right, there is not much you could do, but still I would ask you to help me to confirm my suspicion.
    Is there any tutorial in which I could see if things in my google developer console are set up properly?
    I don't know, I am just speculating. It could be anything, I am trying to cover all bases. I don't give up easily. Please, don't give up on me either.

  • Luís
    • Support

    Hi Vilma ,

    Hope you're doing well today!

    Sad to hear the problems you are having.

    Can you give me access to your admin panel, so I can test with my credentials, just to make sure that it's not an issue in your website?

    If you don't already know, please, follow the link below, to see how enable the staff login:

    http://premium.wpmudev.org/manuals/wpmu-dev-dashboard-enabling-staff-login/

    When you enable this option, please post again!

    Cheers, Luís

  • Luís
    • Support

    Hi Vilma ,

    I tried using my credentials and all worked well.

    1) Are you using always the same project or are you creating a new one each time you try integrate with the GCal API?

    2) Can you try it in a different browser, maybe can be some browser add-on that it's interfering with this?

    Honestly, I am not seeing other options that ask you the access to your google account and test it myself to try figure out what it's happening.

    Cheers, Luís

  • Vilma
    • Design Lord, Child of Thor

    Thank you so much Luís! It was the browser! Who would tell. I was using firefox and when I tried with chrome it did work. I couldn't believe it was that, but you were right. I really appreciate your help.
    Now, if I am not abusing your patience, I have another problem, not related to the plugin, but to the theme, so I don't know if I should open another ticket.
    I am trying to customize it by changing the images of the slider and it keeps giving me an error message when I try to save it (attached image).
    So if you could take advantage of the access to my site you already have, please have a look. By the way, it is happening in both browsers.

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.