Google Calendar API problems in Appointments+

Hi,

We are having problems connecting the Appointments+ plugin to our Google Calendars via the API. We got it to work for some time, then it stopped working. We've gone step by step through the guide on each users profile page, creating the ID's, copying the service email address, sharing the calendar with it etc. etc. etc. , yet we are not able to get it to work.

Even our full time developer is scratching his head.

This is our last attempt to solve this problem, otherwise we will cancel the subscription and go elsewhere.

Please respond as soon as possible.

Regards,
Daniel Runarsson

  • Vaughan
    • Support/SLS MockingJay

    hiya

    thanks for posting.

    have you checked the correct integration mode settings?

    (Select method of integration. A+ -> GCal setting sends appointments to your selected Google calendar, but events in your Google Calendar account are not imported to Appointments+ and thus they do not reserve your available working times. A+ <-> GCal setting works in both directions. This synchronization is not immediate; it requires at least some traffic to your website and not handled less than 10 minutes intervals. To update it manually use "Import and Update Events Now" link which is only visible if the settings let it so.)

    also did you upload each providers keyfile to their calendars to your server using FTP?

    can you also check that the providers aren't using a google business account as I think they would need to pay for gcal service then.

    hope this helps, if you require further assistance, please ask.

  • pxwm
    • WP Core Meltdown

    Hi Daniel,

    Are you able to confirm if you have clicked the 'test connection' link in the 'Google Calendar' tab and if so does it report a successful test message at the top of the page and does it populate the google calendar with a test appointment?

    You indicate you have setup Wordpress users with a google calendar so could you confirm if you have tested the 'test connection' in each Wordpress user profile page?

    Is it also possible you could post all the setting in the 'Google Calendar' tab and at least one of the Wordpress user profile page settings?

    Regards
    SteveB

  • pxwm
    • WP Core Meltdown

    Hi Daniel,

    I've checked your settings and assuming your first screenpost relates to the Wordpress user and the second screenpost to the main Google Calendar then could you log-in as admin and then set the 'Integration Mode' in the 'Google Calendar' tab to 'Integration disabled'.
    This will disable the main calendar as you don't have any private key settings.

    This will remove the 'test connection' from this page.

    Can you then log-out of admin and log-in as one of the Wordpress users that you have integrated the google API.

    It must be the Wordpress user log-in not Admin.

    Once logged in can you select 'Profile' on the left hand side menu and scroll down and at the bottom there will be a 'test connection' link.

    Can you click to confirm if reports successful and if it does could you check in the relevant google calendar.

    Please let me know the results

    Regards
    SteveB

  • kasmir
    • New Recruit

    Thanks SteveB

    I have done as you requested and still get the same result when I try testing connection on user profiles. I logged in as two different users who are both set up as the step-by-step guide requires. Test connection yields no success message, only reloads the page (in a few seconds).

  • pxwm
    • WP Core Meltdown

    Hi Daniel,

    I've checked your settings and also checked your user profile and I was surprised to find that being logged in as admin allowed me to click 'test connection' at the bottom of your Wordpress user profile.

    I clicked on the 'test connection' and even though I didn't receive an error message it didn't reload correctly as scrolling down no longer shows the GCAL API information.

    I noticed your plug-in is currently at v1.2.4.1 and the current version is 1.2.8.
    I'm hopeful upgrading will resolve your problems.

    Could you please upgrade and then log-in to your Wordpress user profile and click the 'test connection'.

    This link should only be available when you are logged in to the actual Wordpress user.

    Please let me know how you get on.

    Regards
    SteveB

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.