Google Calendar is not syncing with my Appointments +

My Google calendar isn't syncing with APP +. We only have one provider on our site. There is also another provider listed as "no service provider" Could this be holding things up? Also, can you help me sync faster than 10 minutes?
My website is in development right now and the URL is:
http://dev.angelwisdom.me
Thank you,
Annemarie
please email me at: [removed]

please do not share any information in this email unless it is for support purposes.

  • Patrick

    Hi @Colleen

    I've removed your email address from your post as these forums are public and accessible by search engines like the Goog. :slight_smile:

    How have you set the synchronization; App+ to Gcal only, or have you set it to sync both ways?

    Have you double-checked that the keyfile supplied by Gcal is in the correct location?
    wp-content/plugins/appointments/includes/gcal/key/

    ...and that is correctly entered in App+ settings without the .p12 extension?

    Synching faster than 10 minutes is not possible without core code modifications. It may even be limited by the Google API, but I'm not sure of that, so I won't say it :slight_smile:

  • Colleen

    Synchronization is set to both ways.
    Key file is in the correct location.
    Key file correctly entered without the .p12 extension.

    In fact, the test connection link returns the following result:

    [Appointments+] Test is successful. Please REFRESH your Google Calendar and check that test appointment has been saved.

    The test appointment does, indeed show up on the Google calendar, but existing appointments in that Google calendar are not being blocked out in the Appts+ calendar, so Appts+ on my website is showing available appointments where there shouldn't be any.

  • pxwm

    Hi @Colleen

    If you only have one 'Service Provider' and you have only setup the GCal settings in the A+ 'Google Calendar' tab then you may wish to try the following:-

    Change the 'Allow Service Providers for Google Calendar API Integration' field from 'Yes' to 'No

    Then Save and try

    This field is set to 'Yes' if you have set up the GCal settings for the specific 'Service Provider' in their Wordpress profile settings.

    Regards
    SteveB

  • Colleen

    Still not working. I wonder if it's in the shortcodes? I think what may be happening is the 'No specific provider' Appts+ calendar is displaying and I want to display Colleen's Appts+ calendar. Since we have only one provider, I took out the 'select a provider' drop down. Do I need to put it back in? I thought it might confuse people if they have to 'select a provider' when there is only one. I am attaching a screen shot of the short codes I used on the "Make an Appointment" page.

  • pxwm

    Hi @Colleen

    I have made some changes to my original post so you may wish to re-read

    If you don't want users to have to select the single 'Service Provider' then you could try the following:-

    Log-in to your Wordpress dashboard as Admin
    Select A+ Settings
    Select 'Service Providers' tab
    Then make a note of the 'Service Provider' ID to the left hand side of the named 'Service Provider'

    Then revise your shortcode [app_services] with the following:-

    [app_services worker="X" autorefresh="1"]

    And replace the 'X' in the shortcode with the ID.

    Then Save
    This will 'force' the 'Service Provider' schedule to be displayed and when you select the 'Service' the page will be auto refreshed and the 'Show available times' button will not be displayed.

    Then Select the 'Working Hours' tab
    Then Select the 'no specific provider' from the dropdown and set all the 'Work?' fields to 'No'
    Then Select the single 'Service Provider' from the dropdown and set the relevant 'Work?' fields to 'Yes' and the Start and End times.
    Then Save

    You may also wish to check the settings in your Google account for your calendar product as another wpmu member has had a similar problem and the following steps appears to have solved theirs. The following post applies: https://premium.wpmudev.org/forums/topic/how-do-i-sync-existing-appointments-in-appointment-to-my-google-calendar#post-538654

    To check your settings:-

    Login to your Google account
    You may have to Select 'MyAccount' top right
    Then Select 'Products' on the left hand side
    Then Select the 'Calendar'
    Then click on the dropdown of the calendar you have setup for A+
    Then select Calendar settings
    Then click 'Share this calendar' link at the top left
    Then check the following:-

    On the left it should indicate the developers email address, xxxxxxxxx@developer.gserviceaccount.com, you have entered in the A+ 'Service email account address' field in the A+ 'Google Calendar' tab and these should match.

    If they do then check the 'Permission Settings'
    These should be set to:-

    'See all event details' - if not you can select from the dropdown
    'Make changes to events' - if not you can select from the dropdown
    Make changes AND manage sharing

    If they are not set to these can you please change and then save

    If you had to make any changes to these settings could you try making an appointment in the A+ front end, ensuring you select your single 'Service Provider' from the dropdown, unless you have revised the shortcode as per my suggestion earlier in the post, and see if it populates your Google Calendar.

    If all the settings were correct and as you only have one 'Service Provider' you may wish to try the following:-

    Login to your Wordpress dashboard as Admin
    Select A+ Settings
    Select 'Google Calendar' tab
    Take a copy of ALL the data in ALL the fields in say notepad and then save to your computer.
    Then set 'Allow Service Providers for Google Calendar API Integration' field to 'Yes'
    Then set the 'Integration Mode' field to 'Integration disabled'
    Please Note: You don't need to delete the data in the fields
    Then Save
    Then logout as Admin

    Then Login to the Wordpress dashboard using the 'Service Provider' login details
    Then select 'profile' from the left hand menu
    Then scroll down to the section is called: 'Appointments+ Google Calendar API'
    Then set the 'Integration Mode' field to 'A+<-> GCal (Synchronization)'
    Then populate all the other fields with the relevant data
    Then click the 'Update profile' button at the bottom of the page

    You should then see a 'Test Connection' link
    Click this to confirm it indicates a success message at the top of the user profile page.
    If you get the success message could you check that your Google Calendar has been populated with a test appointment matching the time you clicked the 'Test Connection' link

    If you do then could you try making an appointment in the A+ front end, ensuring you select your single 'Service Provider' from the dropdown, unless you have revised the shortcode as per my suggestion earlier in the post, and see if it populates your Google Calendar.

    Regards
    SteveB

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.