Google Calendar not adding appointments since the latest update

Updated the Appointments plugin today and since then new appointments are not syncing to my google calendar.

  • Nithin

    Hi WebTesa,

    Hope you are doing good today. :slight_smile:

    I checked your system, and it seems like you haven't configured the Google Calendar, as seen in the screenshot you haven't authorized access to your Google Application yet, could you please generate access token, and check whether it works fine for you?

    If you are find it difficult to generate access token, please reset it, and configure the keys once more, so that it works fine. I also tested in my system with the latest plugin, and Google Calendar works fine without any issue.

    Please do let us know how that goes, have a nice day. :slight_smile:

    Kind Regards,
    Nithin

  • Nithin

    Hi WebTesa,

    Hope you are doing good today. :slight_smile:

    I checked your system, and it seems like you haven't configured the Google Calendar, as seen in the screenshot you haven't authorized access to your Google Application yet, could you please generate access token, and check whether it works fine for you?

    If you are find it difficult to generate access token, please reset it, and configure the keys once more, so that it works fine. I also tested in my system with the latest plugin, and Google Calendar works fine without any issue.

    Please do let us know how that goes, have a nice day. :slight_smile:

    Kind Regards,
    Nithin

  • Kasia Swiderska

    Hello WebTesa,

    That is strange - calendar should not get disconnected like that. Can you tell what is period between those disconnections?

    Also please enable debug log and wait for the next time it will get disconnected. If there is error causing that it should show in debug log. To enable it, open your wp-config.php file and look for define(‘WP_DEBUG’, false);. Change it to:
    define('WP_DEBUG', true);
    In order to enable the error logging to a file on the server you need to add yet one more similar line:

    define( 'WP_DEBUG_LOG', true );

    In this case the errors will be saved to a debug.log log file inside the /wp-content/directory.

    Depending on whether you want your errors to be only logged or also displayed on the screen you should also have this line there, immediately after the line mentioned above:

    define( 'WP_DEBUG_DISPLAY', false );

    The wp-config.php is located in your WordPress root directory. It’s the same file where the database configuration settings are. You will have to access it by FTP or SFTP in order to edit it.

    I would need then to see content of the debug.log file - so please upload it to service like a Dropbox and paste link here.

    kind regards
    Kasia

  • Nithin

    Hi WebTesa,

    Hope you are doing good today. :slight_smile:

    Thank you for making that clear, and for sharing the debug.log file, I'm able to replicate the same issue. I'm marking this as a bug, and will ask the developer to give a closer look, and if possible a quick fix for this issue. At the moment, I don't have an exact ETA on when a patch related to this bug will be released, will keep you posted, once I get an update on this asap. Have a nice day. :slight_smile:

    Kind Regards,
    Nithin

  • Nithin

    Hey WebTesa,

    Hope you are doing good today. :slight_smile:

    Sorry for the delay in getting back to you, I tested this in my system, and I wasn't able to replicate this, ie once I submitted appointment to Gcal, I deleted the appointments in the dashboard, and I was able to notice the appointments got removed form Gcal too.

    Am I missing something here? Please advise, the steps to replicate this, so that we could help get this fixed asap.

    In addition to some code issues, the new update has a closing tag missing and is causing problems on my page.

    Not, able to notice any such issue in my server. This seems to be a site specific issue, could you please point out where you are noticing the closing tag being missed,eg page, or file name), so that I could check, and see what's the exact issue here.

    Please advise what's being missed here, so that we could have a better idea regarding this. Have a nice day ahead. :slight_smile:

    Best Regards,
    Nithin

  • WebTesa

    Never had a problem with this page before the update, after the update it has messed up my page, when I remove the appointment shortcodes the page returns to normal that is how I know it is caused by the code in appointments plugin. http://thebraidguru.com/appointment/

    I just removed another appointment in the dashboard and it is still on my Google calendar, I have to remove it manually from my Google calendar.

  • Nithin

    Hi WebTesa,

    Hope you are doing good today. :slight_smile:

    I just removed another appointment in the dashboard and it is still on my Google calendar, I have to remove it manually from my Google calendar.

    I was able to notice some anomalies, it seems like the Gcal shows up under Reserved by Gcal section, once I removed the appointments from there the appointments got deleted from the calendar. Could you please check whether you get the same issue? I'm also pinging the developer regarding this, so that I could have a better idea.

    It seems like the support access got disabled, please do enable support access, so that we could give a closer look, and see what's being missed here.

    I have pinpointed the shortcode with the missing closing tag [app_monthly_schedule ... notlogged=""]

    I tested this in my system, and it does work fine. However, you don't have to add the attributes as you have shown in the shortcode. Setting the attributes via the appointments shortcode generator should make it work:

    Please let us know once you enable access, so that we could get this sorted. Have a nice day ahead. :slight_smile:

    Kind Regards,
    Nithin

  • WebTesa

    1. No, only personal items I add to my google calendar are showing as reserved by Gcal, not appointments booked through the website.

    2. It does not matter if I use the "new" appointment shortcode generator or if I use the old shortcode that I have been using, the same issue occurs. I have added a test page to demonstrate because I don't want to disturb my appointment page until the issue is fixed. http://thebraidguru.com/testing-app/ This page along with my "appointment page" are the only pages on my site that have the app_monthly_schedule shortcode which is disturbing my page, you can see the gray footer is 100% width on every other page but the ones with this shortcode. This is telling me that there is a missing closing tag in your code, please locate it and fix it!

    Thanks!

  • Nithin

    Hi WebTesa,

    Hope you are doing good today. :slight_smile:

    1. No, only personal items I add to my google calendar are showing as reserved by Gcal, not appointments booked through the website.

    Thanks for the info, I'm letting know the developer regarding this, so that he could give a closer look. Will keep you posted, once I get an update on this issue asap.

    This page along with my "appointment page" are the only pages on my site that have the app_monthly_schedule shortcode which is disturbing my page, you can see the gray footer is 100% width on every other page but the ones with this shortcode. This is telling me that there is a missing closing tag in your code, please locate it and fix it!

    Is the issue only related to the theme footer? I could notice than once I remove the monthly shortcode, the footer does load fine. However, I'm not able to replicate such issue in a default WordPress system. As workaround you could add the following CSS, so that the footer loads like other pages:

    .page-id-6 .footer-bottom-cont {
        width: 128.5%;
        margin-left: -15%;
    }
    
    .page-id-6 .footer-container {
        width: 128.5%;
        margin-left: -15%;
    }

    The above CSS is for the /appointment page, ie http://thebraidguru.com/appointment/

    You can add the code, in your themes Custom CSS section, or via the Customizer, under Appearance > Customize > Additional CSS.

    I hope this should make the appointment page work, I'll bring this into the developers attention, and see whether it's a plugin specific issue. Thanks for bringing this into our attention, have a nice weekend ahead. :slight_smile:

    Best Regards,
    Nithin