Google Calendar sync in Appointments+

When I try to do the test appointment after following the google calendar API setup instructions, I get the message [Appointments+] Google PHP API Client requires at least PHP 5.3 I am new at working with wordpress, have asked my webmaster, and was told that my site should already have PHP 5.3 already. Where do I go from here?