Google Calendar sync is not working correctly

Hi, according to me the syncing between Appointments+ and a connected Google Calendar should happen automatically, right? That is the whole idea of connecting the two. :slight_smile:

But this is not what is happening. When a user cancels their appointment, the status is set to 'Removed'. This does NOT trigger a Google Calendar update. It is not until we manually delete the 'removed' appointments that a Google Calendar update is triggered.

The same goes the other way around: When in the connected Google Calendar an appointment is added the appointment status is set to 'Reserved by GCal' in Appointment+. It is not until we manually change the status to 'Confirmed' that the time slot is blocked in the agenda.

How can we make this happen automatically? The way it works now not acceptable because Appointment+ and the Google Calendar are not syncing the correct way. A change (like a cancellation) in one place should be immediately be reflected/synced in the other place.

I do hope we are missing a setting. :slight_smile: If not, this issue should be fixed as soon as possible. Thanks!

  • Kasia Swiderska

    Hello Carsten,

    But this is not what is happening. When a user cancels their appointment, the status is set to 'Removed'. This does NOT trigger a Google Calendar update.

    I tested this issue on my site and I was able to replicate that appointments are not removed from the gCal - I will ping developer about that issue.

    The same goes the other way around: When in the connected Google Calendar an appointment is added the appointment status is set to 'Reserved by GCal' in Appointment+. It is not until we manually change the status to 'Confirmed' that the time slot is blocked in the agenda.

    Do you have Auto confirm set to "Yes" in "Accessibility Settings"? When you set that to yes, then slots will be set to busy instantly. I tested that on my site and only when auto confirm is not set to Yes, gCal appointments needs manual confirmation.

    kind regards,
    Kasia

  • Carsten from TwelveTrains

    Hi Kasia,

    Thanks for your quick reply! Somehow it's great when issues can be replicated, so thanks for the first one. :slight_smile:

    About the second one: Yes, Auto confirm set to "Yes" in "Accessibility Settings". I tested it again, and today it's working, which is great! What is NOT working is when I delete an appointment in gCal, it is not updated in Appointment+. Could you see if you can replicate that?

    Somehow the system doesn't seem or feel stable. Just now I was able to make 3 reservation for a service with capacity set to 2.

    As you can understand, we are quite reluctant to go live with this plugin.

    Kind regards,
    Carsten

  • Kasia Swiderska

    Hello Carsten,

    ! What is NOT working is when I delete an appointment in gCal, it is not updated in Appointment+. Could you see if you can replicate that?

    No, I could not replicate - I created appointment in gCal, it was imported to WordPress, then I deleted it in gCal and it was then deleted also in WordPress.
    Can you check if in API mode in Google Cal settings you have set "A+ <-> GCal " Synchronization?

    Somehow the system doesn't seem or feel stable. Just now I was able to make 3 reservation for a service with capacity set to 2.

    Would you mind allowing support access so we can have a closer look at this? I tried to replicate that on my site: 1 service - 3 service providers and capacity set to 2 and I was only able to make only two reservations for one slot.
    To enable support access you can follow this guide here:
    http://premium.wpmudev.org/manuals/wpmu-dev-dashboard-enabling-staff-login/

    kind regards,
    Kasia

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.