Google calender syncing incorrectly with Appointments+

Hi,
I really need help with the appointments+ plugin. I have two current problems:

1. I have correctly set up google calendar syncing with the plugin. But when I create an appointment, it shows up on google calendar with the wrong time. It is consistently one hour off. For example: I made an appointment for 3:30 - 5:30pm. It shows up on google calendar as an appointment for 2:30 - 4:30pm. Please advise. I have feeling this is some weird glitch with daylight savings. But it needs to be fixed ASAP.

2. My second problem (which just started happening since I updated the plugin), is with the scheduling portion that the customer sees. Lets say we have a blank day with no appointments and someone wants to book a 2 hour appointment. The scheduler only gives them the option of booking every 2 hours... so they could start at 10:00 am, or 12:00pm, or 2:00pm ... but the scheduler does not offer the inbetween time slots, for example if they wanted to start the 2 hour appointment at 11:00 and go to 1:00. Also if they want to schedule a 3 hour appointment, the scheduler only offers starting the appointment at 10:00am, 1:00pm, and 4:00? it makes no sense that someone can't start a three hour appointment at 2:00? please help, we need this to work.

Please advise.
-Leah

  • Sajid

    Hi @Leah

    Hope you are doing good today :slight_smile:

    For first issue make sure your date time settings in WordPress settings and Google settings match exactly. This is most common reason that cause this this issue.

    By default users can book an appointment slot that right after the first one ends. But we have a solution proposed here by our senior colleague Michelle in this thread. This would work for you as well.
    https://premium.wpmudev.org/forums/topic/available-time-slots-in-uneven-hours-question#post-942474

    Take care and have a nice day :slight_smile:

    Cheers, Sajid

    • lhollroc

      Hi Sajid,

      Thank you, I followed the link and was able to solve the second problem with the Durations add on.

      However I am still having problems with the appointments incorrectly syncing with google calendar. All of my time zones are correctly set and I'm not sure what to do. I experienced this all last year and it caused major problems. For half of the year everything's great, it syncs correctly and everything. than the spring daylight savings hits, and it syncs with google an hour off for 6 months. then daylight savings hits again, and it's fine for another 6 months. Please advise.

      Also, another problem that has started occurring is on the page where clients book appointments. The time slot feature covers up a section of the calendar so no one can select the first 3 Saturdays of any month. This is going to be a huge problem unless we can fix it asap. I will attach a screen shot so you can see what I'm talking about. Please advise.

      Leah

  • Sajid

    Hi @lhollroc

    Hope you are doing good today :slight_smile:

    Appointments + uses default data and time settings of WordPress. So if your timezone is under DST then it will use that time and sync with Google accordingly. In your case, if I understand you correctly you have lets say two appointments one is before DST and other one is after DST. The one withtout DST works but the one with DST does not work. Please confirm if I am correct. If yes then I will flag developer of the plugin for their feedback on this matter.

    For second issue its a CSS issue, but please always start new thread for separate topic to get faster response. Its also helps us mange each ticket in its own thread. Make sure you inlucde the link of your appointments page in new thread so our staff member can inspect element and suggest you a CSS code to fix that issue.

    Take care and have a nice day :slight_smile:

    Cheers, Sajid

  • lhollroc

    Hi Sajid,
    Thank you for your response. No, if I follow your response correctly, I don't think what you said is the problem. Everything on the plugin is correct, if we put an appointment in for 3:00 on Monday, the plugin will give the correct appointment time at all times of the year. The problem is when the info syncs over to google. For the whole Winter, the time is correctly syncs with the google calendar. So, for instance, that same 3:00 appointment will correctly sync over as an 3:00 appointment. The problem occurs in the Spring when daylight savings hits. After Day Light savings, the 3:00 appointment becomes a 2:00 appointment on the google calendar. So, it incorrectly syncs for half of the year. Let me know if this makes sense.

    -Leah

  • Sajid

    Hi @Leah

    Hope you are doing good today :slight_smile:

    Yes, I understand your issue and explained it to our developer exactly. He also understood it that for half of the year time does not sync correctly with Google calendar.

    Here is what he said:

    we're always using whatever WP says is current time

    so, no real remedy, unfortunately

    yeah, i get it, but there's no current workaround for DST

    i mean, we do convert the times, but according to what WP says the time is

    Hope that helps :slight_smile:

    Cheers, Sajid

  • Sajid

    Hi @lhollroc

    Hope you are doing good today :slight_smile:

    Well, because when the appointment is created/made the time is not in DST so the WordPress time is standard time, that's why appointments + will send the current time without DST to Google calendar and Google calendar does change all future times as well according to DST.

    Now when the time passes you changed we are now in under DST time, then WordPress also updates all its times according to DST now appointments + knows the correct time because WP says it that's why its changed it accordingly.

    Hope that makes sense and I am sorry for any confusions.

    Take care and have a nice day :slight_smile:

    Cheers, Sajid

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.