Google drive authentication Issue with Snapshot Pro.

I am facing issue while authentication my google drive destination. I am getting this issue:
An error occurred authenticating with Google: Error fetching OAuth2 access token, message: 'invalid_client'. Double check credentials and also I deactivated all my plugins and check it... But still, I am getting this error.
Please help.

  • Adam Czajczyk
    • Support Gorilla

    Hello Micah Marcano

    I hope you're well today and thank you for your question!

    I have accessed your site and checked the GDrive configuration. While I cannot try to authenticate it with your credentials (as I would need to be logged into your Google account!), the setup doesn't look quite right to me.

    First, the Directory ID shouldn't be entire URL but just the string that starts after the /folders/, in your case it would be:


    That is all that should be put into the Directory ID option.

    The more important part (and the one that's most probably causing the error) is the Client ID. Currently it seems to be your e-mail address there. But the ID should look similar to this:

    The ID above is fake but it shows how it should look like. That being said, please go to your Google developrs console, select relevant project and if yo go to the "Credentials" option in the "API interfaces and services" section you should see a list of OAuth 2.0 Client IDs. The ID should be listed there so copy it from there.

    If you do not have them, you will need to create new ones as OAuth 2.0, selecting "webapp" as an application type.

    Best regards,

  • Micah Marcano
    • WPMU DEV Initiate


    We did it in the same way. Even I am only using the ID not entire url.. But even time when it is reload it is by default loading that url.. Even your Chat support team try and support me in all the possible way.. I have also deactivate all the plugin and try to authenticate it with google drive..But it did not work on.. I also created the twice but that also don't work.. Your Chat support team tried with their own credential as well but we don't get any success.
    Please help me with it..
    Thank you in advance.

  • Predrag Dubajic
    • Support

    Hi Micah,

    Your folder and client ID still don't look good I'm afraid.

    Can you try opening your backend in a different browser and then add the details there to make sure autofill is not adding anything different in there, and also, after authentication make sure to save settings on that page one more.

    I have added my account in your destinations and created test snapshots and as you can see on your site the file was uploaded properly.
    So you can check my destination to see how folder and Client ID should look.

    Also, while in Google Console > Credentials make sure to edit OAuth 2.0 client ID and add redirect URI there.

    Let us know how it goes.

    Best regards,

  • Micah Marcano
    • WPMU DEV Initiate

    I check in different browser but still It did not worked for me.. It auto filling the data. That's what causing the error.. I just deleted the plugin and installed it again.. I do the same process with same client id and destination id.. It works fine this time.. It working properly now..

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.