google maps conflict with Divi

That is the response from Elegant themes about the conflict with google maps .
"Hello,
Generally we cannot guarantee support with 3rd party plugins as we have no control over how they are coded and there are too many plugins created to test them all. Most plugins should work however if you are experiencing problems you will need to contact the plugin developer. I apologize for the trouble.

Full Integration with all third party plugins would require a good deal of custom work. We must focus on ensuring that our themes are working as intended and as previewed in our theme demos. "
So i cannot use google maps from Wpmudev because nobody cares to fix the conflict???
Two companies, both one of the best in WordPress coding and support, locate in the same country do not fix compatibility of their products...????