Google Maps conflicting with MU Domain Mapping?

I am using the Google Maps plugin on a multi site installation together with the MU Domain Mapping plugin. I noticed that everything works fine when the site is on its original subdomain. However, after mapping the domain, the Google map isn't displaying well. It is only showing a simple map image, without the dynamic controls and without the marker.

I have tried emptyinh caches and the sort, but that didn make any difference. Since the only thing changed was the mapping of the domain, I guess the problem is over there.

Example of a site where it is working: http://mountainhouse.startnepal.com/contact
Example of a site where it is not working: http://www.metroclinic.com.np/contact

  • Vladislav
    • Dead Eye Dev

    Hello,

    After visiting the links you posted (and by the way, thank you very much for that, such little things make debugging issues so much easier), I noticed that there is a javascript error on the page that doesn't work correctly. The error is caused by duplicate scripts inclusion - once in the header, and once in the footer, which causes them to clash. Since you experienced the same with 2011, we can probably rule out the theme conflict. This could as well be an issue caused by domain mapping interacting with caching, so can we please take this one step at the time and disable the caching plugin first?

  • ruud-yakti
    • WPMU DEV Initiate

    OK. After disabling the cache didn't make a difference, I narrowed the problem down to a conflict with the Better WordPress Minify plugin (http://wordpress.org/extend/plugins/bwp-minify/). You mentioning the double call for the javascript pointed my into that direction.

    After disabling this, the Google Maps worked fine and the call of the javascript in the footer disappeared. I am going to move this to the support forum for that plugin. However, if you have any suggestions on how to prevent this from happening, it'll be welcome.

    Thanks a lot.

  • Kimberly
    • Champion of Loops

    Hi!

    Just checking in :slight_smile:

    I'm guessing that because we haven't heard back from you that you've got your issue worked out or that we have reached the end of our convo here. If you are still having problems or need any other answers on this particular topic please feel free to come back to this thread at anytime. Just be sure to mark it Not Resolved so we don't miss it!

    This ticket is only being Resolved due to lack of activity. It is by no means an action to avoid, brush off or minimize your issue. We are ready and here if you want to re-open at any time and I apologize in advance for any lack of communication if this ticket is being closed in error.

    Thanks for using the WPMU Community!

    Best,
    Kimberly

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.