Google Maps - hide market list won't work

When I go to Map Options to deselect the "Marker List", I hit Okay, but it isn't accepting it; because the list is still showing and when I reopen the Map Options, that is still selected. I'm trying to hide the list below the Map... I'm assuming that's where I should do it. What am I doing wrong?
http://108.167.140.195/~pronica/projects/