Google maps not showing

I added my new Google Maps API Key and updated the wpmu_dev_google_maps plugin, but the Google Maps is still not showing on my site -- I also cannot get into edit mode of Upfront.

"Oops! Something went wrong.
This page didn't load Google Maps correctly. See the JavaScript console for technical details."

  • Adam Czajczyk

    Hello Nicolas,

    I hope you're well today and thank you for your question!

    A recent Upfront release does include fix for Google Maps so make sure that you're using Upfront 1.3.3 (I think you already had a chance to update it) and then:

    - remove Google Maps map from the site (the one that comes from the Google Maps plugin)
    - go to "Upfront -> General" page in your dashboard
    - put your API key there
    - add a generic Google Maps element back to the site

    You may however need to go to the "Upfront -> General" page after removing plugin's map from site and use "RESET UPFRONT CACHE" option (please do not mistake it with "reset layout" and "reset theme" as those would clear your site's layout!!!).

    Let me know please if this worked for you!

    Best regards,
    Adam

  • Adam Czajczyk

    Hello Nicholas!

    I'm glad I could help.

    As for "magnifying glass". I can see in browser that there's a red background applied to this element (via CSS):

    .upfront-output-object input[type="submit"]

    Switching this off in browser CSS editor results in an icon being visible. This is however useful only for testing and I'm not sure where did this rule came from. Have you added any custom CSS to the site? Anything that would include similar selector as the one above?

    If this doesn't "ring a bell" would you mind granting me a support access to the site so I could check it? Here's a guide on this:
    https://premium.wpmudev.org/manuals/wpmu-dev-dashboard-enabling-staff-login/

    Best regards,
    Adam