Google Maps Plugin dose not show the content

Google Maps Plugin dose not show the content.
Everything seems to be correct and the map shows the item and the text "This is you", but the map does not show in the background!
Also both text and links for directions are appearing but when asking for the directions, it asks for both A & B locations! While typing the locations I get this message: "There was an error geocoding your location. Check the address and try again".
Then I get this message after filling in the data and click on "Gert Directions":
"Oops, we couldn't calculate the directions"

In Google Maps control Panel:
Custom fields
Use custom Post Meta fields support:
I change it to know but it keeps changing is back to yes!
Please advice,
Thanks

  • Tyler Postle

    Hey Everest,

    Hope you're doing well today!

    I've been testing this out on my site and it's working correctly for me so far. Could you grant support access? Then I can view your settings and make sure my setup is an exact replica.

    You can grant support access via WPMU DEV > Support > Grant Support Access.

    http://premium.wpmudev.org/manuals/wpmu-dev-dashboard-enabling-staff-login/

    In the meantime, it would be a good idea to run through this troubleshooting guide if you haven't already. Issues like this can often be plugin or theme conflict related.

    Troubleshooting flow chart:

    Look forward to hearing back!

    Cheers,
    Tyler

  • Everest

    Hi again,
    I manage to fix the issue! :slight_smile:
    I had modified the style.css and functions.php. I changed them back to the original form in the child theme, and google map shows up correctly. :slight_smile:
    Remaining:
    1. The map is showing a very small area. I would like it to cover a larger area when customers visit the page :slight_smile:
    2. Still do not understand why there are 2 options for inserting a google map in post editor!
    Thanks again :slight_smile:

  • Sajid

    Hi Everest,
    Hope you are doing good today :slight_smile:

    I am glad to know you have figure out the first issue.

    1. The map is showing a very small area. I would like it to cover a larger area when customers visit the page

    There is option to set the default width and height of Google Maps from Settings -> Google Maps -> Options. Or you can also override this setting per map basis while adding/editing the existing map. While adding/editing map click on Map Options, set the custom width/heigh here and save changes (see screenshot).

    2. Still do not understand why there are 2 options for inserting a google map in post editor!

    I am unable to replicate this issue on my own site. I am only seeing just one insert Google Map button above WordPress editor (see screenshot). It must be any other plugin that you are might have installed that is also adding the other add map button in WordPress editor.

    Hope that helps! Feel free to post a reply if you need further assistance :slight_smile:

    Best Regards,
    Sajid

  • Everest

    "There is option to set the default width and height of Google Maps from Settings -> Google Maps -> Options. Or you can also override this setting per map basis while adding/editing the existing map. While adding/editing map click on Map Options, set the custom width/heigh here and save changes (see screenshot)."

    I am sorry being late on responding....
    The size is fine! I meant that the map shows very zoomed in, and shows a very small area around our locations!
    Any suggestions how to show the map zoomed a bit less!?
    Thanks :slight_smile:

  • Sajid

    Hi Everest,
    Hope you are doing good today :slight_smile:

    You can set the map zoom from Settings -> Google Maps > Options -> Default map zoom. You can select predefined zoom level here (see screenshot). Or you can also set the custom zoom level your self by clicking on advanced link and then adding numbers to adjust the zoom level (see second screenshot).

    Hope that helps! Feel free to post a reply if you need further assistance :slight_smile:

    Best Regards,
    Sajid

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.