Google Maps plugin not working with directory listings

Hi,

I've followed all the steps mentioned here but when I try to add a listing the maps location option does not appear on the add listing page. Just FYI I've configured all the necessary settings for this to work but no luck.

  • Milan

    Hello Nausheen

    Hope you are well today and thanks for asking us. :slight_smile:

    I am able to show map on listing post type, I used default WYSWYG editor of listing post type to inject map in it. Please see this attached screenshot. :slight_smile:

    So Would you please grant me support staff access so that I can check in depth regarding your issue ?. You can grant me support access via WPMU DEV > Support > Support Access > Grant Access.

    Cheers,
    Milan

  • Nausheen

    Hi Milan ,
    I'm using Buddypress so I want the Map address field to show up on the front-end "Add listings" page when user wants to create a new listing. I've created custom fields for Map Address, Latitude & Longitude using custompress that came with the directory plugin but still doesn't work.
    And since the Map Address field is not present on the "Add Listings" page the map doesn't show up on the listings page.
    Do you need admin access for this?

  • Adam Czajczyk

    Hello Nausheen,

    I read the original guide on integration and went through all the steps. It turned out that there's a bug in a plugin in a part that displays the custom fields in BuddyPress. This has already been reported to the developer and a fix is ready. It should be shipped with an upcoming release.

    Meanwhile, I've attached a .zip file to this post that includes a "quick patch" that should fix the issue and make Map Address field show up on BuddyPress "Add Listing" page. To apply it to your site please follow these steps:

    1. Download an attached file
    2. Extract it to your local drive
    3. Access your server via FTP
    4. Go to this folder on your server:

    /wp-content/plugins/directory/ui-front/buddypress/members/single/directory

    5. upload the "update-listing.php" file from your local drive (the one from extracted .zip file) to that directory; agree to overwrite

    From now on the "Map Address" field should be available on front-end for you and it should work as described in a guide that you followed.

    Could you please apply the patch and let me know if it helped?

    Best regards,
    Adam

  • Nausheen

    Hi Adam Czajczyk this patch helped, thanks so much!!

    Since we're on the subject of directory listings, I wanted to know why does my listings page display the listings in such a weird way. I'm using the premium KLEO theme, but the plugin itself should have some set attributes to set the page properly. Have a look below - the featured image takes over and the listing does not appear in a pleasant way :slight_frown:

  • Adam Czajczyk

    Hello Nausheen!

    I'm really glad that the patch helped.

    Since you granted an access I tried to visit the site's dashboard to review it against that "look" issue that you asked. Unfortunately, as I already explained in your other thread, I wasn't able to access it. There's an error saying that the admin of the site did not granted access which usually means that something went unexpectedly wrong or there's an additional security layer that's preventing access.

    That said, could you please try revoking and then re-granting access for me? Please also make sure that there are no additional limitations (such as e.g. IP or geolocation based) on login.

    Best regards,
    Adam

  • Adam Czajczyk

    Hello Nausheen!

    There's no "staging1.thetwelvers.com" site registered with your account here. Is this a sub-site in MultiSite network or a separate site? If it's a separate setup, it should be registered with your account (which simply means installing and logging in with WPMU DEV Dashboard plugin) here.

    Yet, I'm still not able to access the only site (thetwelvers.com) even though you re-granted access. It's possible that it's something on my site then so we could try a bit different approach. Would you mind creating a temporary admin account for me on your staging site? Once it's done please send in:

    Subject: "Attn: Adam Czajczyk"

    - Mark to my attention, the subject line should contain only: ATTN: Adam Czajczyk
    - Do not include anything else in the subject line, doing so may delay our response due to how email filtering works.
    - Link back to this thread
    - login URL and admin account login credentials (may be a temporary admin account) data
    - Include FTP log-in details (hostname, username & password)
    - Include any relevant URLs for your site

    Please use our contact form here http://premium.wpmudev.org/contact/.
    Select "I have a different question" from the drop-down list.

    Please be sure to make a full backup of your entire site first!

    I should then be able to access your site directly and having also an FTP access I'd be able to make some changes if necessary in order to make it work.

    Best regards,
    Adam

  • Adam Czajczyk

    Hello Nausheen!

    The markers on directory map are now showing up. The fix here turned out to be quite easy (though equally difficult to notice) fortunately :slight_smile:

    You were using this shortcode to display the map:

    [agm_map overlay="true" query="post_type=directory-listing" width="100%" show_posts="true" zoom="10" show_images="false" show_markers="true"]

    I adjusted it so it now is

    [agm_map overlay="true" query="post_type=directory_listing" width="100%" show_posts="true" zoom="10" show_images="false"]

    The difference is that now there's no "show_markers" attribute which is not necessary here but the clue is the post type: you used the "directory-listing" post type but it's actually a "directory_listing".

    After changing this now markers work.

    I hope that helps!

    Best regards,
    Adam

  • Nausheen

    Hi Adam Czajczyk ,

    Thanks for fixing this? Do you know how can I get rid of the listing list at the bottom of the map?

    Another issue I'm facing now is as soon as I activated Events+ plugin and it's "Event Capabilities" add-on, it created an issue with all my Directory Plugin pages as well as some of my wordpress pages. Due to the Events+ Event Capability add-on, I now get a 404 error when logged in as a 'Subscriber/Participant' on pages which function well as soon as I deactivate the add-on.

    Please could you have a look? Credentials are the same

    Thanks so much!

  • Predrag Dubajic

    Hi Nausheen,

    Thanks for fixing this? Do you know how can I get rid of the listing list at the bottom of the map?

    You can hide this by adding some simple CSS code:

    .agm_mh_marker_list {
        display: none;
    }

    Another issue I'm facing now is as soon as I activated Events+ plugin and it's "Event Capabilities" add-on, it created an issue with all my Directory Plugin pages as well as some of my wordpress pages

    I did some tests with E+ capabilities and it looks like this issue is specific to "Check the box if you want to restrict the media files to the author only" option available in capabilities add-on, as soon as I disabled it I could access the posts again, both on your and my installation.

    I will move this thread now to E+ section and create a bug report for our developers.

    Thanks for bringing this up to our attention.

    Best regards,
    Predrag

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.