Google Maps Prevents Pagination of BuddyPress Members Page

This could be just the site I'm working on but maybe others have also experienced this.

I have Google Maps installed in a BuddyPress site. I had the map showing at the top of the members directory page but it prevented pagination of the page and caused all members to display on the page together. This wasn't so much of an issue when we had fewer than 800 members but now we're at 900+ members the server refuses to let the BuddyPress member loop script fully run (it times out). When I place the map at the bottom of the page, pagination works and only a subset of the members show per page but the pagination links cease displaying at the bottom of the page i.e they show at the top only.

Other than stopping the map displaying on the members page, is there another solution?

I know I can put the map into the member's loop template using a shortcode but I'd like a more permanent fix, if possible.

  • aecnu

    Greetings DDV,

    Thank you for bringing this item to our attention.

    Fantastic news that you folks have 800+ members - congratulations and great going!

    Regarding the time outs they are directly related to the hosting they are on and the php script timeout setting. In addition, the more powerful the host, the less time it will take anyway.

    Other than stopping the map displaying on the members page, is there another solution?

    Sure, get a better host or hosting package with a better server/hosting configuration.

    Ah, a little digging - Host Gator - cheap hosting for amateurs but it could be worse let me tell you.

    So there are your solutions other then rearranging the positioning of the map.

    Increase the php script run time max_execution_time of your current hosting package or upgrade/change your hosting package for more powerful and more time.

    Thank you for being a WPMU DEV Community Member and have a GREAT weekend!

    Cheers, Joe

  • DDV

    The site will be moved to a VPS then dedicated server when its outgrown its current shared server. That's always been the plan. I can't increase the maximum script execution time without upsetting HG :slight_frown: For now, I've activated clustering of member locations on the map. The map's working much better but pagination is still not working on the member page when the map is enabled.

    I'll mark this as resolved but I suspect a bug in the map's PHP, maybe a missing closing tag.

    Thanks Joe.

  • aecnu

    Greetings DDV,

    Thank you for your input and feedback and I will check to see what the lead developer thinks of this pagination issue and the possibility of the missing tag or some kind of coding issue?

    Concerning max_execution_time as shown here and being pre-set at 240 as shown here: http://wpmu-hosting.org/phpinfo.php ( if memory servers HG is 30) in which you will see the configuration is fantastic for running WordPress and almost anything else one can come up with and a more friendly to WordPress host that is centered on making WordPress installations fly.

    Let me know if you want me to re-open this ticket and see about having the lead developer dig in.

    Cheers, Joe

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.