Google Maps Pro: Geotag my posts not showing marker in sidebar

I have used Geotag my posts add-on and placed [agm_gwp_geocoded_posts] in the widget using Shortcode Widget. It is working fine but maps marker is not showing and placement is not right.
Please help!

  • Dimitris
    • Support Star

    Hello there Marnick van den Brand,

    hope you're doing good today! :slight_smile:

    The Geotag my posts add-on can only be used with the [agm_gwp_geocoded_posts], which displays a single map with all markers coming from this add-on.
    In order to display the map marker of current post via the Google Maps Widget, you should follow another path:
    1) open the post you want and click on the Google Maps button in Visual editor, like inserting a map (don't worry, no map will be inserted in the end)
    2) create your new map, don't insert it inside page content, but go to Map Settings

    3) in there, select Associate map with this post and click on the Apply button

    4) set your widget and you should be good :wink:

    Warm regards,
    Dimitris

  • Nastia
    • Support Rock Star

    Hello Marnick van den Brand

    Hope you are well!

    You can add multiple markers in one single map by clicking in a Drop Market button. Insert a map into a page as usual, by clicking on Insert Map button. Please see this screenshot:

    If you are using [agm_gwp_geocoded_posts] shortcode, with geotag posts, it should show all markers on this map.

    Let us know if you have any further questions!

    Kind regards,
    Nastia

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.