Google+ not Importing

Howdy doodly,

Before I start, I saw the same issue here https://premium.wpmudev.org/forums/topic/not-importing but as it was resolved, I decided to start a new post.

As the title suggest the google+ plugin isn’t importing posts from my Google+ page.

I set up the keys and got authenticated and all that jazz but not posts are showing. I tried displaying them as a widget and had the same issue.

As with the post mentioned above I don’t see any test button.

I have downloaded and installed the file given without any luck.

Any help would be great.

Cheers,

D

  • Kimberly
    • Champion of Loops

    Hey D!

    After reading the post above I will urge you to forget the “Test” button.

    I believe the correct button is an “Authenticate” button

    Just to make sure, have you followed these instructions:

    1 Create a project in Google API Console

    2 Under “Services” tab, turn “Google+ API” to ON

    3 Under “API Access” click “Create oAuth Client Access.” Fill in your details and use this as your

    “Authorized Redirect URIs”: http://yoursite.com

    4 Copy your Client ID and Client secret values and paste them in the fields below

    5 Save your plugin settings and click the “Authenticate” button

    I know it’s tedious but I have to ask :slight_smile:

    Also you will need to fill in the Page and Profile ID’s

    Can you supply a screenshot of your settings?

    Just so we can see where to start?

    Best,

    Kimberly

  • dunskii
    • Site Builder, Child of Zeus

    Ok, I tried starting fresh and deleted all the setting and recreted it all in the google apis etc, still with no luck.

    See attached for my settings

    Cheers,

    D

    Edit: The screen shot shows my details in the import from other pages, that is me just playing around. There’s no difference with or with out it.

  • Kimberly
    • Champion of Loops

    So you have Google API on and OAth Created in the app?

    (as a long shot can you check to see if it works on a default twenty wp theme?)

    I’m at my knowledge end on this plugin so I will flag the developer to see if he can offer any information here.

  • Vladislav
    • Dead Eye Dev

    Hi,

    The “Test” button not appearing indicates that there is probably something going wrong with the token exchange. Are you perhaps hosting your site on a Windows server, and do you have cURL PHP extension active? Also, is this perhaps a Google Apps account?

  • dunskii
    • Site Builder, Child of Zeus

    Thanks for jumping on board VeBailovity,

    Its a linux server and have just checked the phpinfo and cURL is enabled.

    Nope it’s not an Apps account though I was thinking of trying to see if I have any luck using it with one. If you think that may cause more issues I wont.

    Also just incase it helps heres my cURL info – libcurl/7.23.1 OpenSSL/0.9.8b zlib/1.2.3 libidn/0.6.5

    Cheers,

    D

  • aecnu
    • WP Unicorn

    Greetings avdi,

    Welcome to WPMU Dev!

    @avdi and D – as a long shot since it has not been mentioned is this possibly a mod_security problem by any chance?

    To find out try adding this line as the top line of your htaccess file:

    SecFilterEngine Off

    If you get an error then we know it is not activated on your host ~or~ they do not allow the disabling from the htaccess file.

    Please advise.

    Cheers, Joe

  • aecnu
    • WP Unicorn

    Greetings D,

    Sorry to hear that adding the mod security disabled statement caused you some grief.

    I have never had an issue with it nor received an error but this is probably because on my hosting servers not only do I have mod_security enabled but I also allow it to be disabled via htaccess for just these types of instances and troubleshooting.

    The error you received in a clear indication that your hosting either does not use mod_security or they do not allow you to disable it.

    In addition, I do these types of tests via ssh and it takes just a second to change the statements. Good move having made a backup file :slight_smile:

    Please advise if now 6 days later you are still having an issue.

    Look forward to hearing from you in any event.

    Cheers, Joe

  • avdi
    • New Recruit

    aecnu,

    I’ll definitely try that line, but I am absolutely not disabling mod_security across my entire site for one nonessential plugin. If that turns out to be the culprit, is there a more specific mod_security tweak you can suggest?

  • aecnu
    • WP Unicorn

    Greetings avdi and D,

    @avdi most hosts do not use mod_security at all and the host may not have configured it properly or too restrictive. If the host were truly worried that disabling it would cause a security breach, do you think they would allow you to in fact disable it?

    @d you may want to ask your host about it, it certainly cannot hurt.

    Thank you both for your input.

    Cheers, Joe

  • avdi
    • New Recruit

    @aecnu:

    With all due respect, that’s a silly question.

    Dreamhost is a highly developer-friendly host, and in my experience, also quite competent in the features they roll out. They are not concerned about their *own* security being compromised; but they *highly* recommend that their users enable mod_security (although they do make it optional – like I said, developer friendly) so that the user sites are not compromised.

    They allow their shared hosting users to insecure software if they wish, as I discovered recently when my site was cracked using an exploit in a shoddy WordPress plugin. But they also seek to provide safer defaults and good advice.

    The onus is on WPMU here to explain why your plugin – among all the ones I use – requires a highly recommended security plugin to be COMPLETELY DISABLED, as opposed to selectively tweaked.

  • Kimberly
    • Champion of Loops

    I love that you love Dreamhost so much. :slight_smile:

    I read the wiki, and it does seem that they allow you to tweak the mod access, and do in-fact state that it can cause errors when enabled.

    I don’t believe that Joe was suggesting that you are required to Disable the security plugin. I believe that he was suggesting that it could be an issue and perhaps disabling would help. You are more than welcome to use Dreamhost’s guidelines for allowing processes in lieu of disabling.

    We do not have any Dreamhost specific issues that we account for, so offering specific advice per your hosting account is hard for us. Joe does have a tremendous amount of server experience and would not offer any suggestions to a member that he would not offer to his own clients.

    Please understand we try to first troubleshoot the issues, not server specific problems. I am sorry if this caused any confusion.

    Regards,

    Kimberly

  • aecnu
    • WP Unicorn

    Greetings avdi,

    Thank you for your valuable feedback and input, it is greatly appreciated.

    We are indeed having a friendly conversation and a meeting of the minds :slight_smile:

    I also find it humorous probably as you have found some of my statements, that you mentioned They are not concerned about their *own* security being compromised; but they *highly* recommend that their users enable mod_security (although they do make it optional – like I said, developer friendly) so that the user sites are not compromised.

    If their security is compromised the whole entire network is at risk to include their end users and all servers and sites within, security indeed starts with the host.

    One small php file and I can take out an entire server including all sites and everything else within, though I will leave that file unnamed here for security reasons.

    Relative to mod_security, they can put in custom rules which could possibly be causing a problem, this is why I had recommended disabling mod_security, not to keep it off forever, but to just see if that is causing the issue.

    That is my job here, resolving issues anyway that I can as long as it is legal.

    Regarding servers, though you here that Host Gator and many others have had security breaches left and right, you have never heard this about my companies network, ever.

    Servers and networks are my specialty since 1998 and I am Global Network Administrator for AECNU (US) and since 2008 GCS LTD. (Europe)

    Just Google dreamhost security breach and then the same for AECNU or GCS LTD – not a single mention, the only item even remotely related for either is referring to Host Gator.

    Those searches tell the tale :slight_smile:

    Back to the original topic though, have we gotten anywhere with this folks or is this issue closed?

    Please advise.

    Cheers, Joe

  • dunskii
    • Site Builder, Child of Zeus

    To be honest I haven’t looked at this for a while. Been busy trying to write how to guides for the last little while (fun fun). Simplifying and removing tech jargon from seo and social media articles etc, so “10 year old can understand it” is hard. But after talking to a few close customers, thats what they want and understand.

    Any hoo, I’ll have another play with it later in the week and let you know.

    D

  • aecnu
    • WP Unicorn

    Greetings D,

    Sorry for the delay in a reply here, this ticket somehow got away from us in the back end of the ticket system and I came across it today.

    Please may I have an update as to the status of this issue?

    I do see the lead developer was pinged in here but do not see that he made his way in here yet.

    Please advise.

    Cheers, Joe

  • Steven Mautone
    • Flash Drive

    Hello,

    It looks like this thread has been inactive for a while.

    I’m having the same trouble. The plugin is Network Enabled, but I am configuring a single site in my network. I have a Google Apps account on Google+. I’ve properly created the project within the Google API Console.

    I added SecFilterEngine Off and got the same 500 Error noted above. This is my own server, so I could update whatever I need to get this working, btu I’m not clear what needs to be done.

    What is causing Google+ to not get imported? ow can I resolve this?

  • aecnu
    • WP Unicorn

    Greetings extremis,

    I have no idea why it is not importing since I am unable to replicate any problems on my test production servers.

    However, considering that there are a bunch of settings that need to be exact for this plugin to operate correctly and that if doing a copy and paste of API keys etc. it is possible that an empty space is copied in the end of the item that has been copied and pasted.

    This is where I would personally start looking and triple checking is in the My Google+ page ID, My Google+ profile ID, My Google+ App settings both client ID and Client Secret.

    Other then this, we will need to await lead developer input to possibly get this handled.

    Please advise after triple checking the above mentioned items and checking for spaces if the issue has subsided or persists.

    Cheers, Joe

  • dunskii
    • Site Builder, Child of Zeus

    Hi Joe,

    Getting this plugin working is pretty far down my priority list.

    Will probably re look at this plugin if and when google release a auto post api.

    Until then I’m just going to use floating social for g+ integration.

    D

  • aecnu
    • WP Unicorn

    Greetings D,

    Thank you for that input and what a massively better idea in my opinion then jumping through all the hoops required to get this going, much easier to get Floating Social going indeed.

    Thanks again D for the KISS solution that I had not thought of.

    Cheers, Joe

  • dunskii
    • Site Builder, Child of Zeus

    Yeah Joe,

    I think that is the hardest thing about using WordPress, there are so many cool plugins available its very easy to turn a trimmed chimpanzee into a 200Lb gorilla.

    I’m now in the middle of a major trim the fat operation with my MS install, to the point I’m coming to the realization that a fresh install maybe easier to deal with.

    D

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.