Google Search Console reporting 5xx error

Hi there, I recently migrated this site from Joomla to WP and the hosting to you guys. The site was ranking #1, P1 for the keyword "deep sea fishing sydney" it fell for a bit but it's back up there.
My question is Google are reporting a large number of 5xx error but they are all to http: urls and now the whole site enforces https: and the submitted sitemap has no http: urls.
Is it safe to just ignore this or how to I tell Google to stop trying to index http?
Thanks
Peter

  • Ash
    • WordPress Hacker

    Hello Peter

    Did you check the database? I recommend checking the database if there is any instance of http://

    You can export the database, open in an editor and then search for "http:".

    If there is no instance of http, then I think you can ignore this. Google will folllow the update sitemap on certain interval.

    Have a nice day!

    Cheers,
    Ash

  • Peter
    • WPMU DEV Initiate

    Hi Ash
    I actually identified that the urls the bot is finding are on the old website at SG which was a Joomla site in maintenance mode. The nameservers of the domain are Cloudflare and they point only to you guys so I don't know how this is possible. All the bad urls Google finds start with http and http://www.w or w.www or http://www.ww.ww and I found that any combination of prefix other than www would actually go to the old site. I have now blown away the directory and database of the old site and now when I try and visit the urls I either get a 403 e.g http://www.ww.w.deepseacharters.com.au/ or I get an Internal server error e.g. http://www.w.deepseacharters.com.au/ru-ru/blog/page-30.html
    It looks like this is still being generated by SG, how is this possible when they no longer have anything to do with the domain other than being the registrant? You host the site and Cloudflare the DNS?
    Regards
    Peter

  • Nithin
    • Support Wizard

    Hi Peter,

    Sorry to hear about the issue. If I'm not wrong with the new Google Console, DNS error isn't part of 5xx error anymore, and it should be listed separately.

    If there isn't any such DNS issue reported in the Console side other than 5xx, and since the URLs are pointing to the Old Website URL, sounds like Google was still crawling the old website URL, could be mostly via the sitemap, or via old URLs in the robots.txt file.

    Could you please check the URL inspection Tool:
    https://support.google.com/webmasters/answer/9012289

    And see whether it gave any further information about the source of these URLs are from your current website, or not. A screenshot would be helpful too.

    Also, please check the robots.txt, and sitemap.xml files to ensure whether the links present in there are pointing to the correct URL.

    The sitemap does look fine when I try to check the listed links under:
    yoursiteURL.com/sitemap.xml

    Please let us know how that goes so that we could give a closer look if needed.

    Regards,
    Nithin

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.