Google+ set up settings problem

Hi

I have set up Google API as directed and I'm getting the following error from Google when I click authenticate;

Error:redirect_uri_mismatch

The redirect URI in the request: http://www.example.com/ did not match a registered redirect URI

When creating the the project Google selects;

Authorized Redirect URIs: https://example.com/path/to/callback which I change to http://www.example.com/ as directed in the settings. I've also tried leaving the default type URI and still no joy.

Any ideas?