Gravatar issue for one specific user

Hi,
For some reason I cannot get user jmoore (a superadmin) gravatar to show up on his blogs. He does have one set in gravatar. We've even went and changed it a set a different photo to see if that would fix it, but his pic still does not show up for some reason. His Avatar does show up on stuff such as by his blog on the archive page. My site appears to pull two images (gravatar and avatar) depending on the location of particular one and his Gravatar is the only one there seems to be an issue with. Here is one of his blogs for example. https://myreadyroom.com/how-to-pick-a-technique/

BTW: I have granted support access on our site if that helps.

  • Ash
    • WordPress Hacker

    Hello Shane

    If you are sure he has gravatar set, then I think this could happen due to a conflict. I can see you are using smush CDN and HB gravatar cache. If that cache is the issue, then it will take some time to use the new gravatar appear on the site.

    But to double check, would you please run a conflict test? Please deactivate all plugins including smush and HB, and check if the problem gone. If so, then enable all plugins one by one and find which one is having conflict. You need to do the same with themes as well.

    You can find the flowchart here: https://premium.wpmudev.org/docs/getting-started/getting-support/#chapter-1

    This is highly recommended to take a backup before running a conflict test.

    Let us know how it goes. Have a nice day!

    Cheers,
    Ash

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.