gravity forms registration with Protected content (automated)

Hello,

i checked out the following ;
https://premium.wpmudev.org/forums/topic/where-do-i-put-gravity-form-registration-for-protected-content
but still need some clarification.

Objectives :
- use PC with a simple single membership level, simply to block pages/images etc.
- use GF (user registration add-on) for a simple quick registration.
- Therefore, using GF, the user registers and "automatically" gets access to blocked/protected content.

I honestly would use PC alone but cannot achieve as simple registration as GF;
-"Remove Email Verification" does not work with BP.
- GF allows ONLY email and username (Gravity Perks for auto login), password is auto generated and emailed.
- i edited the "register" page to ONLY have [ms-membership-register-user] and yet still it shows the default "Add Membership Level" - (screenshot 1)
- if left with the default short codes the registration page always has the same "Add Membership Level" by itself (screenshot 2), then has to jump to the form.

so basically i have decided on GF but when registered the users have to be added to the membership level manually to access the blocked pages/images etc.

- What short code/page/redirect to i have to add to GF exactly to have them automatically added to the membership level ?
- Could this be a feature request as PC registration is not flexible like other form builders ?
ie. using "formidable pro", "gravity forms" etc. and other registration options/plugins, the choice can be available to have WP users automatically added to the membership (protected content).

Ok,
i almost got it to work 100%
i basically choose the PC "register" page as a "confirmation" page in GF (screenshot 3),
but i still saw (screenshot 1) with the form and membership level and had to hit "sign up" again.

sorry for being so long winded,
thought it best to explain my situation as best as possible.

any kind assistance in this would be greatly appreciated.

  • Vinod Dalvi

    Hi @Randall,

    I hope you are well today and thank you for your detailed questions.

    - What short code/page/redirect to i have to add to GF exactly to have them automatically added to the membership level ?

    i almost got it to work 100%
    i basically choose the PC "register" page as a "confirmation" page in GF (screenshot 3),

    It seems from your above reply that you have already managed to get it work but if not then please advise.

    - Could this be a feature request as PC registration is not flexible like other form builders ?

    Sure I will move this over to the features & feedback section. This way it can be considered for future development, and we can also see what other community members think about the feature request.

    but i still saw (screenshot 1) with the form and membership level and had to hit "sign up" again.

    This is happening on your site because you are using the memberhsip registeration shortcode in the same page which you have set as register page in the Membership Pages Settings.

    To hide membership level on the regiter page you can try adding the following CSS code in the style.css file of your child theme or add it in your site using the following plugin.

    http://wordpress.org/plugins/simple-custom-css

    .ms-membership-form-wrapper .ms-form-price-boxes,
    .ms-membership-form-wrapper .ms-move-from {
    display: none;
    }

    If hiding the membership levels doesn't work for you then try using the shortcode like following on any other page which is not membership page.

    [ms-membership-register-user membership_id="2069"]

    In the above shortcode the Membership ID is used to assign to the new user. This field is hidden and cannot be changed during registration. Note: If this membership requires payment, the user will be redirected to the payment gateway after registration.

    Kind Regards,
    Vinod Dalvi

  • amused

    thanks for the reply but my question i do not believe has been answered directly !!!

    This is happening on your site because you are using the memberhsip registeration shortcode in the same page which you have set as register page in the Membership Pages Settings.

    i do not know if to laugh or cry honestly, certainly not laugh.

    this plugin has been hailed as the new and improved "membership" yet hmmm....
    i have seen and on the forums and experienced only PAIN myself for what should be really simple stuff.

    This is happening on your site because you are using the memberhsip registeration shortcode in the same page which you have set as register page in the Membership Pages Settings.

    are you serious ?!?!?!?!?!?!?!?!?!?

    i showed how the default short codes as well as the ones i choose was worthless yet no solutions.

    i DO NOT wish to create a child theme on my theme to make your plugin work, it should NOT be that way !!!

    there are so many membership plugins out there and i was holding out on this with the ignorance of wpmudev's support.

    can u make this clear for me ???

    shall i cancel my elite membership ?
    does wpmudev ONLY make plugins for developers or business owners as well ?

  • Vinod Dalvi

    Hi @Randall,

    I think i should have made it more clear for you.

    I am trying to make it clear once again.

    - i edited the "register" page to ONLY have [ms-membership-register-user] and yet still it shows the default "Add Membership Level" - (screenshot 1)

    Ok,
    i almost got it to work 100%
    i basically choose the PC "register" page as a "confirmation" page in GF (screenshot 3),
    but i still saw (screenshot 1) with the form and membership level and had to hit "sign up" again.

    These are the above your replies that you have posted in your initial question.

    From the above replies it seems you want to remove the default "Add Membership Level" and only display registration form on the "register" page.

    Please correct me if i am wrong.

    So after accessing admin area of your site using support staff access i saw that you are displaying the registration form in the register page by adding the schortcode ms-membership-register-user in it but also setting this register page as a membership register page in the Membership Pages settings.

    Now let me tell you what is happening.

    Whenever you set any page as a membership register page in the Membership Pages settings then on that page by default the "Add Membership Level" gets displayed regardless whether you add any shortcode in that page or not.

    And you are adding the shortcode ms-membership-register-user in that page so along with the "Add Membership Level" the registration form gets displayed.

    The default "Add Membership Level" won't get displayed in the page if you use the shortcode ms-membership-register-user in any other page which is not set as a membership register page in the Membership Pages settings.

    For your reference i have also attached some screenshots from my site as admin area of your site is not accessible now due to pop up authentication.

    Please advise if you have more questions.

    Regards,
    Vinod Dalvi

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.