Gravity forms will not display inside popup

I am trying to show gravity form inside your popup window. I've disabled all plugins except for gravity forms and your plugin. None of the form shows in the popup. Please help.

  • calvinrogercanas

    Hey there @Drew Lundgren,

    Hope you're well! :slight_smile:

    I got this error while trying to visit the site.. perhaps fix these errors first:

    Mixed Content: The page at 'https://dev-cms.infousa.com/r/janitorial-services-leads-commercial-cleaning-leads-salesgenie/' was loaded over HTTPS, but requested an insecure script 'http://www.youtube.com/player_api'. This request has been blocked; the content must be served over HTTPS.
    (index):1 Mixed Content: The page at 'https://dev-cms.infousa.com/r/janitorial-services-leads-commercial-cleaning-leads-salesgenie/' was loaded over HTTPS, but requested an insecure script 'http://a.vimeocdn.com/js/froogaloop2.min.js'. This request has been blocked; the content must be served over HTTPS.
    (index):1 Consider using 'dppx' units, as in CSS 'dpi' means dots-per-CSS-inch, not dots-per-physical-inch, so does not correspond to the actual 'dpi' of a screen. In media query expression: only screen and (-webkit-min-device-pixel-ratio: 2), only screen and (min-resolution: 144dpi)
    (index):429 Uncaught SyntaxError: Unexpected token <

    This is cause by a file loaded from external source but use http instead of https. Are there any plugins relating to VIMEO?

    Looking forward for your reply! :slight_smile:

    Best Regards,
    Calvin

  • Adam Czajczyk

    Hey Drew,

    I hope you're well today.

    I've set "Load PopUp using" option to "WordPress AJAX" and indeed the popup shows without a form. However I found that the form actually is there but for some reason it has an inline css rule "display:none".

    I'm not quite sure what's causing it but a quick workaround would be to add:

    .gform_wrapper {
    display:block!important;
    }

    somwhere in your theme's css file, preferably at the very end. "!important" is important here becouse otherwise the above rule will not override that inline style. Also it would be much better not to change theme's stylesheet and create child theme instead but one way or another - this fix should help.

    Cheers,
    Adam

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.