group avatar crop issue

Hi,
I'm pretty sure this worked before I installed the avatar plugin. After reading how it is not to be used with buddypress, I went and removed all the components. I've also since upgraded to bp 1.1.2. I deleted the directory and installed new.

I see no cropping tool whatsoever in buddypress on the group page and have tried both IE and Firefox.

Any suggestions?

I don't think it is a permissions thing since the image gets uploaded fine and displays, it's just that it only displays the top corner.

I removed the edit to .htaccess, I don't have any cache plugins enabled. I removed the avatar.php and PNG files, I'm uploading an image that is 488 by 488 pixels as shown in the attachment.

Thanks for any help you can offer.

  • Richie_KS

    hi raymondmannion

    did you follow the upgrade instruction on buddypress forum?
    it seems the site had bp_is_blog_page() function error where this is supposed to work in bp 1.1+

    this problem happed when some upgrade error or missing update
    on bp core...you might want to recheck or update the buddypress
    again.

    in my experience, for a zero problem upgrade, it is best follow step like this:

    *before upgrade buddypress

    1. remove widgets and deactivate all plugins including buddypress
    2. delete wp-content/plugins/buddypress
    3. refresh or clear cache of the site
    4. upload new buddypress plugins to wp-content/plugins
    5. !important - delete wp-content/bp-themes if you are upgrading from older structure to new bp 1.1+ structure.
    6. reactivate all plugin - buddypress first.
    7. visit the site.

    cheers

  • raymondmannion

    @andrew
    Thanks for the message. The site is actually tkdunion.org

    I have been using a non-buddypress theme quite a bit because the home page looks a lot nicer than the buddy-fun theme for the moment and my client only cares about the look at the moment and less about the functionality.

    I'm going to follow the instructions by richie_ks and try to deactivate and reinstall. I'll post again if I need help.

    Thanks again for the excellent support.

  • raymondmannion

    Hi again,
    I'm having an issue with the crop tool not working. I think this all began when I tried to implement the avatar plugin which I subsequently removed.

    I'm currently flipping back and forth between the BuddyFun theme and the Buddy Magazine theme but both have the issue.

    I get this message in my error console:
    Error: jQuery("#avatar-to-crop").Jcrop is not a function
    Source File: http://tkdunion.org/register
    Line: 178

    How would I troubleshoot this? Below is some of the page source.
    Thanks for any suggestions you can provide.

    <script type="text/javascript" src="http://tkdunion.org/wp-content/themes/bp-fun/_inc/js/jquery-1.2.6.js"></script>
    <script type="text/javascript" src="http://tkdunion.org/wp-content/themes/bp-fun/_inc/js/spy.js"></script>
    <script type="text/javascript" src="http://tkdunion.org/wp-content/themes/bp-fun/_inc/js/tabber.js"></script>
    <script type="text/javascript" src="http://tkdunion.org/wp-content/themes/bp-fun/_inc/js/scroll.js"></script>
    <script type="text/javascript" > jQuery.noConflict();</script>
    <script type='text/javascript' src='http://tkdunion.org/wp-includes/js/jquery/jquery.js?ver=1.3.2'></script>

    further down, I see:

    <script type='text/javascript' src='http://tkdunion.org/wp-includes/js/jquery/jquery.js?ver=1.3.2'></script>
    <script type='text/javascript' src='http://tkdunion.org/wp-content/themes/bp-fun/_inc/js/ajax.js?ver=2.8.5.2'></script>
    <script type='text/javascript' src='http://tkdunion.org/wp-includes/js/jcrop/jquery.Jcrop.js?ver=0.9.8'></script>

    It seems like jquery is there and so is jcrop. Any ideas how I would troubleshoot this? Just disabling plugins might isolate the issue, but I still need my plugins? Any useful articles out there on managing javascript?

  • raymondmannion

    Disabling the plugins resolved the issue. Fortunately, the conflicting plugin wasn't as mandatory as I thought. It was the Wordpress Google Calendar plugin. I thought I might have to learn javascript to correct the issue, but for now, I'm going to simply leave the plugin out of the equation.

    I guess it's pretty standard troubleshooting - disable all plugins and reactivate one at a time.

    Thanks @andrew