Group Calendar description area not bound by center column

I have the BuddyPress Group Calendar plugin working and we love it. The only thing, the description area, where we can enter an event description, has expanded to the right to overlap my right column. It's not a huge problem, but it gives the impression that something is not quite right.

Is there a fix for this? Perhaps no one was aware of it.

I'm running all current versions of WordPress and BuddyPress, and my theme is BuddyBoss, which is highly supportive of BuddyPress.

Any help is greatly appreciated.

Best Regards,
Kevin

  • aecnu
    • WP Unicorn

    Greetings Kevin,

    Thank you for bringing this item to our attention and for the screen shot as well in which I can clearly see the item but do not know how to fix it :slight_frown:

    Therefore I will see if I can get the lead developer in here with his invaluable insight into this plugin for his advice/advise for us.

    Though this may take a bit longer then a normal ticket, I will try to get him in here asap.

    Cheers, Joe

  • Aaron
    • CTO

    I'm not sure how you can fix it, problem is the visual editor can't fit in that small a space.
    LIne 1111 of bp-group-calendar.php looks like this:

    if (function_exists('wp_editor')) {
    					wp_editor('', 'event-desc', array('media_buttons' => false, 'dfw' => false));
    			} else {
    					the_editor('', 'event-desc', 'event-desc', false);
    			}

    You can just change it to:
    <textarea name="event-desc"></textarea>

    That should remove the visual editor.

  • kevin_m__schafer
    • New Recruit

    Hello @Aaron,

    Okay, I will try this. So, to be clear, the above 7 lines of code come out and in their place I put in your line of code. Is this right?

    I will be able to do this as soon as my domain is successfully switched to my new provider.

    I will post back most likely by tomorrow afternoon, at which time I will mark the thread as resolved.

    Thank you for your help.

    Best,
    Kevin

  • kevin_m__schafer
    • New Recruit

    Hi @Aaron,

    Your fix works perfectly! I'll save the page code to make for any easy fix when the new upgrade is released.

    This issue that you've helped me with might make for an option in the next release: provide a setting to disable the visual editor.

    Best,
    Kevin

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.