Group email giving lots of errors front end and wp admin with php 7

i have actually tried asking for help with this previously but i believe the support access for that site may not be up because i have installed, deleted and installed again and again using Softaculous and manual installs, with and without caching, deactivating all plugins except buddy press and still get the same problem.
i have asked SiteGround and quite a few times as well and cannot get a solution there.

can anyone figure out these errors ?
i have increased the main php memory n the server. wordpress memory etc.
- on SiteGround "cloud" not shared.
now the problem only shows with php 7.0.4
and switching to 5.6.1.9 the issue goes away.
But on MAMP PRO locally with php7 it works fine.
i also spun up a free 3 day trail on CloudWays again using php 7 and no problem there.
so the issue i am thinking has to be with SiteGround server set up but they insist all is fine with my server and cannot determine the issue.
as mentioned i tried with and without their varying caching levels.

any kind assistance in this would be GREATLY appreciated !!!
support access granted on this current install mentioned in this ticket form.
kind regards.