GTmetrix and Google PageSpeed still saying to optimize images

I have smushed, then re-smushed all 170 images in my media page; however, the same 10 or 12 images that were listed as needing optimization before I installed your plugins are still showing needing optimization. I have flushed website cache and cleared browser cookies etc. I also re-tested several times to be sure. I did a live chat with support, and they asked that I submit a ticket. I've included 3 screenshots. 2 are google pagespeed (1 desktop, 1 mobile. same images), the other is GTmetrix.

Thanks in advance!
Jon

  • Nithin

    Hi Jonathan,

    I'm able to notice this difference in Google Page speed for your smushed images, I'll have to ping the developer for his opinion, and a will ask to give a look regarding this. Please do note that developers work round the clock with many critical issues, and hence have a slow response time. Either myself, or the developer will keep you posted.

    Please let us know if you still need any further assistance. Have a nice weekend. :slight_smile:

    Kind Regards,
    Nithin

  • Jonathan

    Thanks Nithin,
    I went ahead and completely deleted the images it listed, manually changed their sizes, manually removed EXIF data, reuploaded them, and this got the number from 10+ images needing to be optimized down to 3. One is HTML code that is used to verify my credentials on an external site (psychologytoday.com image), the next is my logo, and the final one is a picture that I cannot figure out why it needs optimizing as it's not HTML code, nor is it something I built in photoshop (logo). Its the Budgeting65x65 image.

  • Nithin

    Hi Jonathan,

    Hope you are doing good today. :slight_smile:

    Sorry for the delay, glad to know that you have managed to find a workaround. I just checked your website, and I was able to notice these, could you please enable support access, so that we could give a closer look.

    Please let us know once you enable support access, so that we could help get this resolved asap. Have a nice day. :slight_smile:

    Kind Regards,
    Nithin

  • Nithin

    Hi Jonathan,

    Hope you are doing good today. :slight_smile:

    The logo wasn't compressed, as you were uploading the image through Appearance > Site options . I have replaced the image from the media gallery(Gate-logo.jpg), and now it doesn't show in Page Speed, and it seems to work fine.

    Regarding the second image, Budgeting-65x65.jpg, it would be the same, the current image is not compressed, and is not present in the media library, at moment. But, I wasn't able to find how the image was added. Would recommend, you to check, and change that to a compressed image to fix it.

    The third image, is an external link, unfortunately Smush Pro cannot compress external images, coming from other server. You'll have to replace this image, in order to get this optimized.

    I hope this helps.Please let us know if you still need any further assistance. Have a nice day. :slight_smile:

    Kind Regards,
    Nithin

  • Jonathan

    Thanks Nithin,

    That makes sense with the logo. I have no idea why the Budgeting image wasn't compressed as I uploaded it a couple of times . . . but it worked this time, so I'm not worried about that.

    New issue is not on PageSpeed, but instead on GTmetrix.com . It is listing several images that were not listed before, and I just uploaded them today, and they do show Smush stats, so it looks like they were optimized, but GTmetrix is saying that they could be compressed further. 4 of these are pix of people (and my dog), the 5th is a logo like the Psychology Today one, but this one is a picture, not external . . . it too shows that smush did smush it, yet its showing up as needing optimization. Here are the GTmetrix messages. . . weird thing is, only the Psychology Today one shows up in PageSpeed:

    Losslessly compressing https://gatehealing.com/wp-content/uploads/2016/08/Therapy-dog-e1472445056581.jpg could save 100B (2% reduction). See optimized version.
    Losslessly compressing https://gatehealing.com/wp-content/uploads/2016/09/Seth-Houdeshell-LCSW.jpg could save 53B (2% reduction). See optimized version.
    Losslessly compressing https://gatehealing.com/wp-content/uploads/2016/09/Kirsten-Brunner-LPC.jpeg could save 14B (1% reduction). See optimized version.
    Losslessly compressing https://gatehealing.com/wp-content/uploads/2016/09/Jennifer-Dunham-CHt-LPC-s.jpeg could save 167B (4% reduction). See optimized version.
    Losslessly compressing https://gatehealing.com/wp-content/uploads/2016/08/good-therapy-verification.jpg could save 108B (4% reduction). See optimized version.

  • Nithin

    Hi Jonathan,

    Hope you are doing good today. :slight_smile:

    This is really odd, as the images are only shown in GTmetrix. Did you resize these images manually through photoshop, as you have mentioned before?

    Since these images are already smushed, I couldn't smush the images further. Could you please upload the original size images in your media library(Smush disabled) so that, I could test this further by smushing, and checking their size.

    It looks like Smush couldn't verify your WPMU DEV membership so Pro features like Super-Smush may not work correctly. If you think this is an error, run a re-check or get in touch with our support team.

    I was able to notice this error when I tried to Smush images, maybe there is an issue in connecting with our servers. Could you please try resetting your API key, by clicking the RESET API KEY button at the bottom of the Account page. You'll have to login into your WPMU DEV dashboard plugin, once you reset your API keys.

    Once done, please try smushing, and resizing these images through the plugin. If you still have issues, please do let us know, and also make sure to please provide the full size images in your Media library.

    Kind Regards,
    Nithin

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.