GZip and Browser Caching disabled

GZip and Browser Caching are shown as deactivated. Though based on the Pingdom tools, leverage browsing caching is at 86% and GZip compression is shown as enabled at the checkgzipcompression.com

There is something that blocking Hummingbird to check the GZip and Browser Compression status.

The site has SSL installed which is temporarily deactivated, and the host is SiteGround. CloudFlare is not configured, SiteGround is not forwarding the DNS to CloudFlare

So far these actions have been done:
- Deactivated all plugins and switched to default WordPress theme
- Renaming .htaccess files.

SiteGround confirmed that no rules in .htaccess file aren't being overwritten by server settings.

Please advise

    Ken Kimbrell

    Hello Shannon-

    Basically what it is saying is that your Apache server is not configured to accept gzip compression requests. You will need to talk to your hosting provider and ask them to enable mod_deflate if on an Apache server. Or ask your hosting provider to enable ngx_http_gzip_module for NGINX.

    If your hosting provider tells you that it is enabled then we can look into other options, such as plugin conflicts.

    Let us know how we can help!

    Take Care,

    Ken - WPMU DEV Support

    Shannon Routley

    Hi Gurus,

    I've just got off the horn with SiteGround. We added the following code to htaccess:

    <IfModule mod_deflate.c>
        SetOutputFilter DEFLATE
        <IfModule mod_setenvif.c>
            # Netscape 4.x has some problems...
            BrowserMatch ^Mozilla/4 gzip-only-text/html
    
            # Netscape 4.06-4.08 have some more problems
            BrowserMatch ^Mozilla/4\.0[678] no-gzip
    
            # MSIE masquerades as Netscape, but it is fine
            # BrowserMatch \bMSIE !no-gzip !gzip-only-text/html
    
            # NOTE: Due to a bug in mod_setenvif up to Apache 2.0.48
            # the above regex wont work. You can use the following
            # workaround to get the desired effect:
            BrowserMatch \bMSI[E] !no-gzip !gzip-only-text/html
    
            # Dont compress images
            SetEnvIfNoCase Request_URI .(?:gif|jpe?g|png)$ no-gzip dont-vary
        </IfModule>
    
        <IfModule mod_headers.c>
            # Make sure proxies dont deliver the wrong content
            Header append Vary User-Agent env=!dont-vary
        </IfModule>
    </IfModule>

    I just double checked and the errors in HB Gzip/Caching still remain.
    The long walk of deactivating plugins begins....

    Shannon Routley

    Ok, I deactivated all plugins. No Change.
    I re-installed HB, the error is gone, but HB still indicates that gzip and caching are disabled.

    I'm out of ideas.
    EDIT: I just updated the PHP version running on the server from 5.0+ to 7.0. It doesn't seem to have helped either.
    EDIT 2: HB Minification isn't listing files now. I've run the minification scan 4 times and each time the page loads with the button and no files.

    What else is there to do?

    Thank you kindly,

    Ken Kimbrell

    Hello Shannon-

    Were you able to rectify your problem? From what I can see in your .htaccess rewrite, you are enabling just text/html compression. While hummingbird compresses text/css & text/javascript as well. So the error may be rendering because of that, and you will need to contact your hosting provider to make sure compression is enabled for html/css & javascript files.

    You can run a compression test here:
    http://www.whatsmyip.org/http-compression-test/

    Thank you for being the best part of WPMU DEV, and hope you have a wonderful day

    Ken - WPMU DEV Support