Gzip compression

Gzip compression is just not working. It says to contact support for this.

  • Sajid
    • DEV MAN’s Sidekick

    Hello Switch,

    Hope you are doing good today :slight_smile:

    I am assuming that you are getting issues while enabling GZIP on your site due to mod_deflate module.

    The message suggests that the “mod_deflate” module may not be enabled but that may not always be the case. Please double-check your server for following issues as well:

    – check if there’s a Varnish cache running on server (or any other server-side caching solution) and make sure to purge/empty it

    – make sure that PHP is configured to support zlib library and that zlib output support is enabled; there’s a php.ini setting for this that should be set to “on”:

    zlib.output_compression = On

    In case it’s set to “off” you will want to change it to “on” and restart Apache

    – there’s also a slight chance that not all required MIME types are set to be handled by “mod_deflate” module; it should support at least “text/html”, “text/javascript” and “text/css”

    You may need to contact your hosting provider for these steps but I hope it’ll fix the issue.

    Hope that helps! Feel free to post a reply if you need further assistance :slight_smile:

    Best Regards,

    Sajid – WPMU DEV Support

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.