Gzip Compression

Hello !
This message appers in Gzip Compression:
Gzip is not working properly:

- Your server may not have the "deflate" module enabled (mod_deflate for Apache, ngx_http_gzip_module for NGINX).
- Contact your host. If deflate is enabled, ask why all .htaccess or nginx.conf compression rules are not being applied.

The HTML compression are inactive.
I already checked this file:
https://premium.wpmudev.org/forums/topic/hummingbird-gzip-compression
And add the code :
zlib.output_compression = On
But did seems that did not worked.

Please could you help me ? The images at the website are disapearing when the users access to website, so I´m checking the situation all over the day and clearing the cache all the time.

Please I need fix this issue.

Thank you in advance.
Elisa

  • Jaxom

    Hi Elisa Nakakusu
    You need to contact your hosting company and find out why mod deflate is not working or installed.
    This is a server side issue that can only be sorted by your Hosting Company from what you have described.
    In regards to the images disappearing check if you have what is called Lazy Loading turned on.
    Lazy Loading only loads the image when the user scrolls to the point that image is needed and then loads the image.

    Jaxom

  • Adam Czajczyk

    Hello Elisa Nakakusu

    I hope you're well today and thank you for your question!

    I'm actually not sure whether it's indeed not working compression or a false alert. I tried to check the site with checkgzipcompression.com site but it fails to do so, returning connection errors. The internal Hummingbird's check might also suffer from this but - like I said - I'm not quite sure about it yet.

    I think it would be best to start with getting in touch with your host, just like Jaxom suggested (thanks Jaxom!) to make sure that those requirements given in the error message are sorted out. Then, there's another aspect - your site seems to be loading quite slow, at least for me, so that might in fact cause timeout issues, causing false test results.

    This, together with the "disappearing images" issue makes me think that it might also be "overoptimized" a bit - sometimes too many optimization tools on site and server running at the same time might case issues.

    I would like to take a closer look at your setup then. Would you please enable support access to the site for me? To do this, please go to the "WPMU DEV -> Support" page in your site's back-end and click on "Grant support accesss" button there, then let me know here when it's enabled.

    Please also share content of the .htaccess file of your site with me here.

    Kind regards,
    Adam

  • Elisa Nakakusu

    Thank you very much for your reply Adam !

    I enabled the Grant support access at the both sites that I have the same issue:
    https://portaljapao.com
    https://portalaichi.com

    The both sites are using the same Wordpress Theme and plugins and having the same issues.

    I consulted my hosting service and your response was as follows:
    I checked on the gzip compression further and it's possible there is
    still a plugin or the theme is preventing the gzip encoding. I tested
    non-WordPress files on your site and they confirmed gzip is enabled:

    portaljapao.com/license.txt:
    https://checkgzipcompression.com/?url=http%3A%2F%2Fwww.portaljapao.com%2Flicense .txt

    portaljapao.com/phpinfo.php
    https://checkgzipcompression.com/?url=http%3A%2F%2Fwww.portaljapao.com%2Fphpinfo .php

    If you review the headers you'll see cache-control has no-cache the
    homepage:

    Request URL: https://www.portaljapao.com/
    Request Method: GET
    Status Code: 200 OK
    Remote Address: 67.205.39.9:443
    Referrer Policy: no-referrer-when-downgrade
    Cache-Control: no-store, no-cache, must-revalidate
    Connection: Keep-Alive
    Content-Type: text/html; charset=UTF-8
    Date: Sat, 19 May 2018 20:29:24 GMT
    Expires: Thu, 19 Nov 1981 08:52:00 GMT
    Keep-Alive: timeout=2, max=100
    Link: <https://www.portaljapao.com/wp-json/>; rel="https://api.w.org/",
    <https://www.portaljapao.com/>; rel=shortlink
    P3P: CP="NOI"
    Pragma: no-cache
    Server: Apache
    Transfer-Encoding: chunked
    X-TEC-API-ORIGIN: https://www.portaljapao.com
    X-TEC-API-ROOT: https://www.portaljapao.com/wp-json/tribe/events/v1/
    X-TEC-API-VERSION: v1

    Seems the caching it is not working, the theme status says: no caching plugin detected.
    About the website speed, yes is very slow, sometimes I get a gateway time-out and following your advice about be overoptimized, I checked that my hosting already have a op cache si I deleted my redis op cache plugin.
    But the imagens are disappearing.

    In this job is a total of 4 websites using the same Wordpress Theme, plugins and contents, so I was thinking in do a Multisite, my hosting support this option. What do you think about ?

    Thank you again and if you need more informations please let me know.

    Regards.
    Elisa

  • Predrag Dubajic

    Hi Elisa,

    Thanks for granting access, I was checking your site and noticed that time to first byte (TTFB), or the time that your server responds to request is really hight, it goes from 5 to over 7 seconds, and this is significantly affecting your site performance.
    Did your host check server logs to see if there's anything in there that could be pointing to what's causing such large TTFB?

    I also saw an issue with images not loading when Hummingbird was enabled and that was because you minimized jQuery on your site, once I disabled minification for jquery.js file the images were loaded properly again.
    Asset Optimization could be a tricky tool as it depends on your active theme and plugins, and how their files work after being optimized.

    I would suggest performing a full conflict test by disabling all your plugins and switching to default WP theme to see how the site behaves after that.
    If TTFB is still not lower after that then your host should investigate it further and see what's going on and why the server takes so much time to respond.

    As for the GZIP compression, it seems that only HTML compression is not enabled, so this means that correct modules are active.
    It's possible that this would start working after conflict test as well but it could be the issue with server having predefined values set for these and doesn't allow them to be changed via .htaccess rules that Hummingbird uses.
    Can you check with your host if this indeed the case and if they can either enable GZIP compression for HTML as well, or at least allow it to be changed by using .htaccess rules.

    Best regards,
    Predrag

  • Elisa Nakakusu

    Hello Predarg !
    Thank you for the great support!
    I'm really having performance issues on these two sites.

    And the others say that the response from the server is slow.
    I'll ask the server to check the logs on TTFB.

    About the images not loading, now they are without problems. Could you please explain me better how to disable the minimized jQuery? I am having the same problem with the website http://portalaichi.com

    My host has already made full conflict test by disabling all your plugins and switching to default WP theme and said that speed is normal and that it is probably a problem of my theme or one of the plugins I am using.

    On using the .htaccess file to change the rules, the server said that it uses and even sent me a link for me to do it:
    https://help.dreamhost.com/hc/en-us/articles/216363157-How-

    Please tell me if you need access direct my server to check the .htaccess and I wil send you my ftp information.

    Thank you again and please teach me how to fix images dissappearing in my another website (https://portalaichi.com)

    Best regards.
    Elisa

  • Predrag Dubajic

    Hi Elisa,

    I've disabled minification for your other site as well, to do this it's enough to go to Hummingbird > Asset Optimization and click on Minification option to disable it, here's an example:

    My host has already made full conflict test by disabling all your plugins and switching to default WP theme and said that speed is normal and that it is probably a problem of my theme or one of the plugins I am using.

    Did the TTFB decrease during these tests as well?
    The thing is that number of requests performed by your theme and plugins is affected by TTFB as well, for example, if TTFB is 5 seconds and there are a couple of let's say ajax requests performed by your theme each of them will be taking too much time due to the TTFB.

    Please tell me if you need access direct my server to check the .htaccess and I wil send you my ftp information.

    You can send us your details using our contact form https://premium.wpmudev.org/contact/#i-have-a-different-question and the template below so I can check your .htaccess file:

    Subject: "Attn: Predrag Dubajic"
    - Site login URL
    - WordPress admin username
    - WordPress admin password
    - FTP credentials (host/username/password)
    - cPanel credentials (host/username/password)
    - Folder path to site in question
    - Link back to this thread for reference
    - Any other relevant urls/info

    Best regards,
    Predrag

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.