gzip compression

I cannot do gzip compression. gzip is not working properly.

I have disabled all plugins except Hummingbird to rule out plugin conflict so it must be a server issue:
Your server may not have the "deflate" module enabled (mod_deflate for Apache, ngx_http_gzip_module for NGINX)

I have other sites on the same hosting that have the same issue.
Any tips how to fix this or must I simply contact the hosting company?

Thanks,
Daniel

    Luís

    Hi Daniel Herstedt ,

    Hope you're doing well today!

    Have you tried the suggestion given by my teammate Predrag in the below topic:

    https://premium.wpmudev.org/forums/topic/gzip-is-not-working-properly#post-1101623

    If you don't feel confortable in doing this, can you send us the FTP details of your website, so we can give a look?

    Please send it privately through our contact form:

    https://premium.wpmudev.org/contact/

    Select "I have a different question" for your topic - this and the subject line ensure that it gets assigned to me.

    Send in:

    Subject: "Attn: Luis Lopes"
    - WordPress admin username
    - WordPress admin password
    - Login url
    - FTP credentials (host/username/password)
    - Link back to this thread for reference
    - Any other relevant urls/information

    Cheers, Luís

    Daniel Herstedt

    Hello,
    I'm picking up this thread again since I'm not getting anywhere on this issue. I have 4 sites where I cannot GZIP with Hummingbird. I get the same error message:
    gzip is not working properly:

    - Your server may not have the "deflate" module enabled (mod_deflate for Apache, ngx_http_gzip_module for NGINX)
    - Another plugin may be interfering with the configuration
    If re-checking and restarting does not resolve, please check with your host or open a support ticket with us.

    I have tried disabling all plugins but I still get the error message. Now I have noticed that it is happening with the same hosting company - loopia.se

    I contacted the hosting company and they say they have no blocking for using GZIP. They ask me if I "have tried to put "AddOutputFilterByType DEFLATE" without IfModul-tags?

    I know wordpress, but I don't understand servers. What can I do, or you, to enable GZIP via Hummingbird?

    I find your services excellent and want to keep using them, but I must be able to easily GZIP my sites since they are most of times "slow themes".

    Thanks,
    Daniel

    Luís

    Hi Daniel Herstedt ,

    Hope you're doing well today!

    We will need to investigate this further, to find what is causing the issue:

    1) Have you checked the .htaccess to see if the codes from Hummingbird to enable the GZIP compression were added? Maybe can be some server configuration that is blocking .htacess writes and we will need to add them manually.

    2) Hummingbird makes a request to get files headers in order to detect caching/gzip. This request is made from the server to the same server, so, could the hosting has disabled requests to itself? Can you try contact them, just to make sure?

    However, you can check if the GZIP compression was enabled, using some external tools like:

    https://checkgzipcompression.com/

    https://varvy.com/tools/gzip/

    http://www.gidnetwork.com/tools/gzip-test.php

    I contacted the hosting company and they say they have no blocking for using GZIP. They ask me if I "have tried to put "AddOutputFilterByType DEFLATE" without IfModul-tags?

    From what I understood, the hosting company is suggesting to add the codes without the "<IfModule mod_deflate.c>", so, can you try this code in your .htaccess:

    # Compress HTML, CSS, JavaScript, Text, XML and fonts
      AddOutputFilterByType DEFLATE application/javascript
      AddOutputFilterByType DEFLATE application/rss+xml
      AddOutputFilterByType DEFLATE application/vnd.ms-fontobject
      AddOutputFilterByType DEFLATE application/x-font
      AddOutputFilterByType DEFLATE application/x-font-opentype
      AddOutputFilterByType DEFLATE application/x-font-otf
      AddOutputFilterByType DEFLATE application/x-font-truetype
      AddOutputFilterByType DEFLATE application/x-font-ttf
      AddOutputFilterByType DEFLATE application/x-javascript
      AddOutputFilterByType DEFLATE application/xhtml+xml
      AddOutputFilterByType DEFLATE application/xml
      AddOutputFilterByType DEFLATE font/opentype
      AddOutputFilterByType DEFLATE font/otf
      AddOutputFilterByType DEFLATE font/ttf
      AddOutputFilterByType DEFLATE image/svg+xml
      AddOutputFilterByType DEFLATE image/x-icon
      AddOutputFilterByType DEFLATE text/css
      AddOutputFilterByType DEFLATE text/html
      AddOutputFilterByType DEFLATE text/javascript
      AddOutputFilterByType DEFLATE text/plain
      AddOutputFilterByType DEFLATE text/xml
    
      # Remove browser bugs (only needed for really old browsers)
      BrowserMatch ^Mozilla/4 gzip-only-text/html
      BrowserMatch ^Mozilla/4\.0[678] no-gzip
      BrowserMatch \bMSIE !no-gzip !gzip-only-text/html
      Header append Vary User-Agent

    If none of the above solutions helped you, can you send us the FTP access to the websites in question, so we can try investigate them further. Please, follow the procedure described in this reply:

    https://premium.wpmudev.org/forums/topic/gzip-compression-4#post-1117486

    Cheers, Luís