GZip Compression disabled text/html

I can't enable gzip compression for text/html even if I add the code to the .htaccess file manually.

Screenshot attached.

I have enabled support access.

  • Adam Czajczyk

    Hello nathaningram,

    I hope you're well today and thank you for your question!

    Since you are not getting any error messages, it would mean that required modules are already enabled on your server. Usually, the issue such as this is caused by the way the server is configured. Most likely it's not set to support "text/html" mime type compression.

    In case of Apache this is a matter of "mod_deflate" filters "Filter type" configuration. If this part doesn't work even despite manually adding Hummingbird-generated code to the .htaccess file, it would be best if you could reach out to your host and ask the tech support staff if they could check (and hopefully adjust) it for you on the server.

    Have you already contacted them? If not, please give it a try and let me know about the result.

    Kind regards,
    Adam

    • Praveen Thirumurugan

      Don't worry to enable GZip in every site in your hosting,
      Follow this steps:

      1) Login in to the cPanel of your Hosting.
      2) Go to Software -> Select PHP Version (Search is easy).
      3) Check the 'zip' box at the end.
      4) Now GZip is enabled for the whole hosting files.

      If that doesn't work,

      1) Go to Software -> Optimize Website.
      2) Select 'Compress All Content' and click 'Update Settings'
      3) GZip should be enabled.

      If this also fails,

      1) Try refreshing the website with 'Shift + Refresh'. This will delete all the cache.
      2) Use .htaccess method as described by the host.

      Thanks for posting,
      Praveen Thirumurugan.

  • nathaningram

    Here is the response from my web host:
    ---------

    When I create a test file it appears that html is being compressed with gzip:

    michael@mwineland ~ $ curl -H "Accept-Encoding: gzip" -I http://www.servemycity.com/lwtest.html
    HTTP/1.1 200 OK
    Date: Mon, 24 Oct 2016 22:53:30 GMT
    Server: Apache
    Last-Modified: Mon, 24 Oct 2016 22:52:09 GMT
    Accept-Ranges: bytes
    Vary: Accept-Encoding
    Content-Encoding: gzip
    Cache-Control: max-age=0
    Expires: Mon, 24 Oct 2016 22:53:30 GMT
    Content-Length: 42
    Content-Type: text/html

    The key line there is the following:
    Content-Encoding: gzip

    I did notice that the file has to be above a certain size, if the file is too small it won't bother to compress it.

  • Adam Czajczyk

    Hello Nathan!

    I checked the test page as well and it does seem to be compressed properly. I have then checked the main site with some external tools and it looks like it's compressed as well.

    The issue seems to be a bit different here. There are two consecutive "301 Moved Permanently" redirects on your site in return to an initial request. Hummingbird expects the gzip encoding header to be returned initially and it seems like some online tools are not able to follow redirects as well. It would mean that the message is actually "misleading".

    You may try to test the site with this tool:
    http://web-sniffer.net/

    It does confirm that the gzip compression is enabled on the site. I asked our developers to review how redirects affects compression enabled/disabled messages in Hummingbird but for now I think you may ignore that "false negative" as the site seem to be properly compressed.

    Best regards,
    Adam

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.