GZIP Compression - gzip is not working properly

Hi

When trying to enable GZIP Compression on one of my websites, it displays the error:

" gzip is not working properly:
- Your server may not have the "deflate" module enabled (mod_deflate for Apache, ngx_http_gzip_module for NGINX)
- Another plugin may be interfering with the configuration"

It works perfectly fine on another website on the same servers.

I have tried disabling all other plugins and the error still shows.

Admin access granted.

Any suggestions? Much appreciated.