GZIP compression is not enabled for HTML type

GZIP compression is not enabled for HTML type.

  • Adam Czajczyk
    • Support Gorilla

    Hello Arya Creative

    I hope you're well today!

    I have checked your site and I can see that it's reporting HTML as not compressed. Also, Google PageSpeed insights is reporting the same and other external checks. However, 1an1 checker claims that site is fully compressed (you can check it here)

    I tried to modify compression settings manually in .htaccess but that doesn't change anything (I currently left only Hummingbird compression rules there as they are doing the same as those suggested by 1and1 in this case).

    According to the 1and1 docs the HTML (text/html) MIME type compression is included "out of the box" on their servers but I'm not quite sure how this works on their end. I believe they got pretty much "fixed" setup and we might not be able to affect that much through the .htaccess settings.

    Please note: the compression itself is not preformed by Hummingbird or any other plugin - it's a server-side feature that HB and other plugins can only enable or disable (and, if server allows that, configure some settings).

    What the 1and1 suggests tho is to take advantage of their Content Delivery Network which doesn't seem to be activated for your site. From what I see in their docs, the CDN already provides built-in compression so I would give it a try (it could also be beneficial for site performance and security in other ways) so if you do have an option to enable it in your hosting account settings, give it a try please.

    I would also suggest getting in touch with their support and asking them if they could help with the issue. I'm saying this because we (or plugins) cannot change server configuration in any other way than the .htaccess (or some sort of control panel - if there is any) allows us and it looks like either there's some issue on their end which makes that MIME type not compressed or they could at least try to check server logs to give us some clue (that could be helpful to identify if something on the site is actually "breaking" that compression).

    However, before you do this, I would also recommend to test one additional thing: disable Divi Booster plugin, switch the site temporarily to Twenty Seventeen theme, clear Page Cache and re-check compression again. That's just to make sure that this is not affecting it. Then get back to your theme and if this test doesn't change anything, please try what I suggested above.

    Keep me informed, please.

    Kind regards,

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.