Gzip compression not working

I had some standard Gzip compression code running in my .htaccess file and the Hummingbird plugin said it was only triggering one of the 3 types of compression (which is not ideal). I then copy/pasted the recommended gzip compression code into my .htaccess file but when I have the plugin re-scan, it still shows that I don't have gzip compression enabled. If this matters: I'm running my sites on Rackspace.

What am I doing wrong? I'd like to get Gzip compression fully running on my sites.

Thanks!
Joe

  • Adam Czajczyk

    Hello Joe,

    I hope you're well today and thank you for your question!

    If Hummingbird reports that one type of content is actually gzipped but others are not, that means that the necessary module is enabled on the server.

    The issue here may be either that the remaining "MIME Types" are not configured or it's a "fixed" configuration that you cannot affect via .htaccess. I would suggest getting in touch with your host and asking them whether compression for these other (reported as not gzipped) MIME Types is supported on a server and if so, whether it's specifically enabled on the server or if you are allowed to enable/disable it via .htaccess.

    There's also a possibility that if you are using CloudFlare with your site and it's not integrated with Hummingbird, the plugin will simply return a "false information" so if you are indeed using it, you might want to make sure that it's also configured in Hummingbird.

    If none of that turns out to be the case, let me know please and I'll further investigate it.

    Kind regards,
    Adam