gzip Compression not working

my gzip-compression (Humming Bird) is not working properly. I don't know if it a server problem or plugin. I proved all my plugins but could not find a solution
Could you prove this?
Thanx, Roger

  • Dimitris

    Hey there DeepBlue203,

    hope you're doing good and thanks for reaching us! :slight_smile:

    Could you please confirm that you have the appropriate code either in .htaccess if you're on Apache server or in the corresponding files under nginx?
    The directions are in Hummingbird -> GZIP compression

    This still may be more of a server side issue though. If there's a "mod_deflate" missing error:

    - Contact your hosting provider to double check that "mod_deflate" library is up and running.
    If you need to check the full PHP setup, you can create a file like info.php in the root folder of your WP installation, adding in there
    <?php phpinfo(); ?>
    Then you can navigate to YOUR_DOMAIN_NAME.COM/info.php and check the PHP configuration.
    If you could do that for us, if would be great! :slight_smile:

    - Try to insert the following snippet in .htaccess file of your installation (you will need to connect to your server via FTP or a File Manager through the server's control panel like cPanel)

    <ifModule mod_deflate.c>
    <FilesMatch &quot;\.(css|js|x?html?|php)$&quot;>
    SetOutputFilter DEFLATE
    </FilesMatch>
    </ifModule>

    - check if there's a Varnish cache running on server (or any other server-side caching solution) and make sure to purge/empty it

    - make sure that PHP is configured to support zlib library and that zlib output support is enabled; there's a php.ini setting for this that should be set to "on":

    zlib.output_compression = On
    In case it's set to "off" you will want to change it to "on" and restart Apache

    - there's also a slight chance that not all required MIME types are set to be handled by "mod_deflate" module; it should support at least "text/html", "text/javascript" and "text/css"

    For three last points, you may have to contact your hosting provider support channel.
    I look forward for your feedback/results on this! :slight_smile:
    Warm regards,
    Dimitris

  • DeepBlue203

    Thank you for your answer. I checked my website.

    1: mod_deflate libary: I configured php.ini to prove php-settings
    but i'm not sure, where to find the mod_deflate libary.

    Could you check that for me?-> http://www.youtype.ch/info.php

    2. I added the code-snippet in den htcaccsess-file.

    3. zlib.output_compression = On: I added the code manually in php.ini because there was no so file.

    4. MIME types: I checked it. It seems there is only text/html?

    5. I delete a plugin called WP SuperCache, but doesn't seem to bee influence.

    Thanks for your feedback...

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.